Opened 2 years ago

Last modified 2 years ago

#13167 new Bug Report - General

theme missing menu option support

Reported by: blm-ubunet@… Owned by:
Priority: minor Milestone: unknown
Component: Themes Version: Master Head
Severity: low Keywords: mythbuntu, menu, radiostreams, gallery
Cc: Ticket locked: no

Description

Mythbuntu is likely the most popular theme & the old photo gallery is being removed..

Using mythbuntu theme v.s. mythcenter:-

  • The (new) photo gallery does not work (DNW) in mythbuntu theme.
  • old gallery does
  • listen radiostreams DNW if you have none already!
  • can not add radio streams because no menu options.
  • FE setup Music player options screen DNW
  • possible zoneminder menu option is DNW.

I assumed new gallery & radio-streams DNW & just kept building old gallery.. Thanks.

Change History (8)

comment:1 Changed 2 years ago by blm-ubunet@…

Correction: mythcenterXmas edition theme allows access to new photo gallery. MythcenterWide? does not.

Maybe the decision to drop the old gallery show be revisited.. the new photo gallery does not function very well.

comment:2 Changed 2 years ago by Roger Siddons

What theme versions ?

Gallery works fine for me with Mythbuntu 28.21, Mythbuntu-classic 26.22, MythCenter?-wide 1.7 using all menu themes (Classic, Default, DVR & 'Media Center Theme')

Do you have anything in ~/.mythtv/themes getting in the way ?

"does not function very well" : please be more descriptive.

comment:3 Changed 2 years ago by blm-ubunet@…

Mythbuntu 28.21..

I deleted the contents of .mythtv/themes/ folder & downloaded/refreshed Mythbuntu28.21 & MythCenterXmas1.5 & Wide1.7.

Can now use menu to add radio streams in Mythbuntu theme.; thanks.

New gallery (Images) still only works from MythCenterXmas1.5 edition.

I created /home/mythtv/.mythtv/temp/Images/Photographs folder to stop errors in log.

Does not function well:-

  • 5 - 10 seconds to load lo-res photos
  • resource hog (intermittently)
  • thumbnailed 15 photos & then did no more.

The above folder does seem to contain all the thumbnails.

Other:

  • tiny obfuscated folder icons / so confusing c.f. old gallery.
  • have to learn to use it not & just use it.

I only reported the problem because there was talk of dropping the old gallery from mythbuntu ppa.

If new gallery works for you them close the ticket. I've recompiled with old gallery enabled.

comment:4 Changed 2 years ago by blm-ubunet@…

The folder UI complaint is with the folder icon display & this is a theming problem not the Images (new gallery).

Old gallery folder view is excellent; very clear/obvious in MythCenterWide?.

comment:5 Changed 2 years ago by Roger Siddons

Folders default to 4 thumbnails but you can assign a single image to reduce clutter. Removing them altogether requires theme modification. But the Mythbuntu 28.21 doesn't show folder names so it would be difficult to distinguish the folders with nothing.

.mythtv/tmp is created at startup (Temp storage group). Did you delete it whilst the frontend was running ? Maybe it should handle that better.

I tested master/Mythbuntu 28.21 today and found no problem. However I can understand why the initial scan appears underwhelming. It's mentioned in para 3 at https://www.mythtv.org/wiki/Gallery#Image_Library

In brief, MythGallery only works on a single frontend that has direct access to the photos (local/NFS). There's a long-term goal of moving all media to the backend (Storage Groups) for use by all frontends/webfrontend/API clients. As in Video/Music.

Passing large numbers of images around (for bigger TVs) is intensive so the backend creates a thumbnail cache (the "resource hog"). Until this is complete the frontend uses thumbnails that are created on-demand, so they appear slowly. It also competes with the backend generator so they can appear sporadically (thread contention). You can observe this with '-v file' logging of the backend.

There have been anecdotal reports of images never appearing. If you can capture a '-v file' backend log and a '-v gui,file' frontend log of that ocurring, please post them.

Scanning my 7.5k photos/600 videos takes 2 mins but then a further 30 mins to create the thumbnail cache. During this time Gallery performance is sluggish. It can be mitigated by zooming in to display fewer thumbnails.

However, after the initial setup, subsequent scans are fast. And Gallery runs off the backend thumbnails (faster than MythGallery) and the frontend's image cache (instantaneous).

Last edited 2 years ago by Roger Siddons (previous) (diff)

comment:6 Changed 2 years ago by blm-ubunet@…

I can see that storage groups for photos will be/is a great improvement.

Mythbuntu theme uses 'default-wide' menu folder the default xml files.. This folder, in my install, does not contain 'image -ui.xml' so the menu 'Images' fails. This could be my fault of course.

If I copy over 'image-ui.xml' from 'default' folder then all works.. thumbnails are okay.

But it is way slower (4 - 6x) than old gallery loading photos & my 100 test photos are only 1.4MB..

comment:7 Changed 2 years ago by Roger Siddons

There is only the one image-ui.xml, in 'default'. 'default-wide' xmls are basically the same with the numbers scaled; image-ui.xml uses relative scaling instead. When nothing is found in 'default-wide' the frontend should fallback to 'default'. Sounds like you still have an old ~/.mythtv/themes/default/Mythbuntu*/image-ui.xml kicking around.

You can check what its using with 'mythfrontend -v gui'.

Earlier comments were for a combined frontend. Remote ones will be slower of course.

The photos themselves are only loaded for Slide view. You should see ~6Kb thumbnails in ~mythtv/.mythtv/tmp/Images/Photographs/ on the backend. On first viewing they should be loaded into the frontend's image cache at ~/.mythtv/cache/themecache/*/myth:* After that they should appear instantly.

Are you saying they are slow to appear then ? There is plenty of frontend/backend communication in the process (filename lookup) but it shouldn't be noticeable.

comment:8 Changed 2 years ago by blm-ubunet@…

I was using 'mythfrontend-v gui --loglevel=info', that's how could see that default-wide was being accessed for the Images-gallery section.

Deleted /usr/local/share/mythtv/themes & .xml files in /usr/local/share/mythtv & redid 'make install' mythtv & mythplugins. Now all menus/screens work except one: playersettings is missing from musicsettings-ui.xml. Overall this is a great improvement, many of the menus haven't worked in very long time!

Slow images: Combined FE & BE but only core2duo, Very slow to display actual full screen photo, the thumbnail display seems fine but I haven't used it on large number of hi-res photos yet. Thx.

Note: See TracTickets for help on using tickets.