Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#13189 closed Bug Report - Hang/Deadlock (Duplicate)

mythfrontend hang on autostart

Reported by: e_geiger@… Owned by:
Priority: major Milestone: 29.0
Component: MythTV - General Version: 0.28.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

env:MythTV Version : v0.28.1-62-g36fe0ce
Ubuntu: 16.04.3 LTS
Desktop: xfce4 Version 4.12.2
mysql Ver 14.14 Distrib 5.7.20

desc: During a startup of mythtv the mythfrontend should automatic start. After an reboot there is always the Country+Language Display which pop-ups, even If I am setting the correct parameter it is coming again after an reboot.

  • If I am cancelling the Country+Language Display then I can start with the mythfrontend or mythwelcome without any problem.
  • If I am login from an remote PC with "ssh -Xl <user> <ip-adresse>" then I can start the mythfrontend or mythwelcome without any problem.

Change History (3)

comment:1 Changed 19 months ago by Peter Bennett

Milestone: needs_triage29.0
Resolution: Duplicate
Status: newclosed

Duplicate of #12977. Fixed in MythTV 29.

comment:2 Changed 19 months ago by paulh

I noticed recently on my parents box this is still happening on current master.

It's a combined FE/BE with and SSD for the OS. I think what is happening is the system boots to quick and tries to start the FE before the BE has time to start up properly. You then get a few seconds of the startup screen which clears once the BE is up. I find it quite annoying compared to the old behavior if I'm honest.

comment:3 Changed 19 months ago by Peter Bennett

I added the startup screen for two reasons. When starting up and the backend is slow -

  • To prevent getting the Country+Language display, which is just confusing and useless.
  • To prevent staring at a blank screen for up to a minute while you wonder if anything is happening, especially when using the database or backend wakeup options.

I have noticed that sometimes it shows briefly when everything should already be up and running. Let me know if you have a suggestion for improving it.

Note: See TracTickets for help on using tickets.