Opened 19 months ago

Closed 19 months ago

Last modified 18 months ago

#13421 closed Bug Report - General (fixed)

Segfault in Frontend master: Previously Recorded

Reported by: jpilk Owned by: Peter Bennett
Priority: minor Milestone: 30.1
Component: MythTV - General Version: v30-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have what feels like a new segfault in frontend master, reproducible in F28, el7 and Firestick 4k. F28 says it has created a core dump, el7 reports and exits quickly, Firestick (20190224) needs a device restart.

Code 1, PID 8, UID 0, Value 0 in F28, 0xXXXXXX in el7

The steps to reproduce are ones that I have used quite often in el7, rarely in F28 and only in today's test on the Firestick.

Manage Recordings > Schedule Recordings > Programme Guide > highlight a recording that has not been previously recorded.

E > Schedule Info > Previously Recorded

No recording found, press right or left arrow

'Loading' popup appears and segfault follows. If recordings were identified, it lists them, and will continue on command.

In F28 a file appears briefly in /tmp. I've looked at the Debug wiki but hope the steps above might point to the cause of the problem.

Attachments (1)

20190306_1851_tickets_13397_13421.patch (1.2 KB) - added by Peter Bennett 19 months ago.
This fixes two tickets #13397 & #13421

Download all attachments as: .zip

Change History (9)

comment:1 Changed 19 months ago by jpilk

It works when I use the Escape key. Perhaps the "newness" was just using arrow (or Enter?) instead.

comment:2 Changed 19 months ago by David Hampton

This bug was introduced between commit a29633136d (Jun 17 2017) and a1a5064ab4 (Dec 31 2017).

comment:3 Changed 19 months ago by jpilk

The whole "previously recorded" code was revised in that time frame. Ticket #13135 etc

https://code.mythtv.org/trac/ticket/13135#comment:32

is when the popup was added. But it seems unlikely that I haven't hit the arrow key instead of Escape since then.

comment:4 Changed 19 months ago by David Hampton

Git bisect says that's the one. Commit 61c6429d7b. I can recreate it there, but not in the previous commit.

Gdb says the code is trying to access the first item in an empty array.

Changed 19 months ago by Peter Bennett

This fixes two tickets #13397 & #13421

comment:5 Changed 19 months ago by Peter Bennett

This works but maybe I should change it to check the array length rather.

comment:6 Changed 19 months ago by Peter Bennett <pbennett@…>

Resolution: fixed
Status: assignedclosed

In c08b7ae0e/mythtv:

Previously Recorded List: Fix 2 bugs

  1. Time zone bug - In a USA time zone at 11 PM on tha last day of

the month you can see the following month listed, albeit with
no entries.

  1. Program Guide->select a program that has not been recorded, then

Menu->Schedule Info->Previously Recorded, then press left or right.
This causes a seg fault.

Fixes #13397
Fixes #13421

comment:7 Changed 19 months ago by Peter Bennett <pbennett@…>

In 042c180902/mythtv:

Previously Recorded List: Fix 2 bugs

  1. Time zone bug - In a USA time zone at 11 PM on tha last day of

the month you can see the following month listed, albeit with
no entries.

  1. Program Guide->select a program that has not been recorded, then

Menu->Schedule Info->Previously Recorded, then press left or right.
This causes a seg fault.

Fixes #13397
Fixes #13421

(cherry picked from commit c08b7ae0e7589dbe54d817a1d6296688e576d675)

comment:8 Changed 18 months ago by Stuart Auchterlonie

Milestone: needs_triage30.1
Note: See TracTickets for help on using tickets.