Opened 14 years ago

Closed 14 years ago

#1346 closed defect (worksforme)

BOB deinterlacing flickers after pause

Reported by: steve@… Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: 0.19
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Under Myth 0.19, playing MPEG4 encoded videos on an nVidia MX440.

If the BOB deinterlacer is used then after the video is paused and unpaused the video continues to play but with extensive flickering - looks like it's showing alternately the correct frame and then a very corrupt frame.

Change History (4)

comment:1 Changed 14 years ago by Isaac Richards

Priority: majorminor

comment:2 Changed 14 years ago by anonymous

I think this is the same problem I am having. I would characterize it as studdering though. For me it happens after a pause or change channel, or rew/ff.

It happens with all drivers I have tried (nvidia 6600), but only on 720x480 resolution. If I use another resolution like 800x600 then it doesn't do this.

However when I use the 800x600 resolution then the xorg process usually sits at about 99% (of one processor core on a pentium D 3.2GHz processor). This only happens with bob deinterlacing. Interesting that it studders a bit at 800x600 but it corrects itself quickly, where it doesn't at 720x480.

So basically I am stuck with using 800x600 for now and just hope my cpu doesn't burn up.

It happens with 0.19 and svn (as of 3-11-06)

comment:3 Changed 14 years ago by danielk

Milestone: 0.20
Owner: changed from Isaac Richards to danielk
Version: 0.19

comment:4 Changed 14 years ago by danielk

Resolution: worksforme
Status: newclosed

Can't reproduce with XVideo or XvMC playback with nvidia kernel version 8756.

Note: See TracTickets for help on using tickets.