Opened 4 weeks ago

Closed 7 days ago

#13493 closed Bug Report - General (fixed)

Regression in GetChannelInfoList services API

Reported by: Gary Buhrmaster Owned by: Bill Meek
Priority: minor Milestone: 31.0
Component: MythTV - Services API - Backend Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

It appears (by observation, I have not done a bisect) that the change in e35e97e1a08d79e4bd99072c45daef035e1fd873 may have changed the results of the MythTV service API for GetChannelInfoList? where the list of channels from a specified SourceId? is no longer returned if there is not a capture card attached to the source. I would think there should be a distinction between the program guide usage and the services API usage.

Change History (6)

comment:1 Changed 4 weeks ago by Klaas de Waal

No bisect needed, the API function GetChannelInfoList? does indeed call the modified function.

A question is whether this API function is intended to provide an interface to the existing mythfrontend functionality which shows the program guide, or if this API function is independent and only shares part of the implementation.

This also depends on how applications use the API function; is it used to provide a program guide, similar to mythfrontend, or is it used to provide a channel editor, similar to mythtv-setup? If it is used to provide a program guide then it should not show the channels from an unconnected video source, as these channels cannot be viewed or recorded.

Possibly two separate API functions, or an additional parameter to the existing API function, may be needed.

comment:2 Changed 4 weeks ago by Gary Buhrmaster

My applications use it for a channel editor (as it is part of the "Channel Service" API group which is defined (well, at least defined in the wiki) to be "The Channel service is a collection of methods for editing channels, adding channels, deleting channels, and modifying lineups and XMLTV services.")

There is also the "Guide Service" API group, which is intended (again, from the wiki description) to be used for scheduling and guide presentation (as I don't have applications that utilize that API function, I don't know how it currently interacts with the channels that are not connected, although the API does return the channel visible/invisible to let the applications decide how to handle the cases).

comment:3 Changed 4 weeks ago by gigem

The deleted channels feature I'm getting closer to working on again will definitely require the ability to query channels that are no longer connected to tuner cards. I suggest adding a new parameter, something like tunableOnly, that defaults to off.

comment:4 Changed 3 weeks ago by Bill Meek

Milestone: needs_triage30.1
Owner: changed from Bill Meek to Bill Meek
Status: newaccepted

Testing now. Going with OnlyTunable just because there's already an OnlyVisible parameter.

Last edited 3 weeks ago by Bill Meek (previous) (diff)

comment:5 Changed 3 weeks ago by Bill Meek

Milestone: 30.131.0

comment:6 Changed 7 days ago by Bill Meek <billmeek@…>

Resolution: fixed
Status: acceptedclosed

In 50e2f8eba/mythtv:

Services API: Channel/GetChannelInfoList? misses unconnected channels

Add an OnlyTunable? parameter that defaults to false. It
creates an override to the fix in e35e97 to include
channels that aren't tunable.

Fixes #13493

Note: See TracTickets for help on using tickets.