Opened 7 weeks ago

Closed 4 days ago

#13497 closed Bug Report - General (Fixed)

Significant blocking artifacts with VAAPI

Reported by: madscientist159 Owned by: mark-kendall
Priority: minor Milestone: needs_triage
Component: MythTV - Video Playback Version: v29.1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Attempting to use the VAAPI acceleration support with an AMD Vega GPU is showing significant blocking artifacts that are not part of the original video source. I've attached a couple of screenshots from the same TV recording, one with VAAPI enabled and the other with the standard OpenGL renderer.

This is a Vega 56 GPU on a ppc64le host.

Attachments (2)

mythtv_no_artifacting.png (467.0 KB) - added by madscientist159 7 weeks ago.
Screen capture of playback with VAAPI disabled
mythtv_artifacting.png (665.9 KB) - added by madscientist159 7 weeks ago.
Screen capture of playback with VAAPI enabled

Download all attachments as: .zip

Change History (5)

Changed 7 weeks ago by madscientist159

Attachment: mythtv_no_artifacting.png added

Screen capture of playback with VAAPI disabled

Changed 7 weeks ago by madscientist159

Attachment: mythtv_artifacting.png added

Screen capture of playback with VAAPI enabled

comment:1 Changed 7 weeks ago by Peter Bennett

In V30 there is a new rewritten VAAPI2. Also coming in V31 will be a rewritten OpenGL renderer. These will likely change what you see, hopefully for the better. I recommend upgrading to V30 and trying VAAPI and VAAPI2 there.

comment:2 Changed 4 days ago by mark-kendall

Owner: changed from Peter Bennett to mark-kendall
Status: newaccepted

comment:3 Changed 4 days ago by mark-kendall

Resolution: Fixed
Status: acceptedclosed

VAAPI support has been substantially re-written in master and should now be far more complete. I can't reproduce this issue.

If there are still issues in master (or 0.31 when it is released), please open another ticket and attach a full log from:

mythfrontend -v playback,gpu

If the issue is specific to certain file, then please attach a short clip that shows the problem on your system.

Note: See TracTickets for help on using tickets.