Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#1351 closed defect (invalid)

Segfault in EPG view

Reported by: florianangehrn@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.19
Severity: medium Keywords:
Cc: Ticket locked: no

Description

hi all

first, thank you very much for version 0.19 now i'm able use mythtv like i want (no prebuffering pause anymore...)

i examined the following bug: while in epg view i can use the arrow keys to move arround but as soon as i use the key 'x' on the keyboard to set the preview window to the actual channel, and then use the arrow keys again, mythtv crashes with a segfault

kernel 2.6.14-gentoo-r2 qt 3.3.4-r8 gcc 3.3.6

mythtv infos


Library API version: 0.19.20060121-2 Source code version: Unknown Options compiled in:

linux release using_v4l using_oss using_alsa using_ivtv using_lirc using_x11 using_xv using_dvdnav using_xrandr using_opengl_vsync using_frontend using_backend

using hauppauge pvr-500 (mce)

Attachments (2)

mythtv-0.19-fixes-crash-v-all.gz (37.0 KB) - added by risto@… 13 years ago.
backtrace run with '-v all'
mythtv-0.19-fixes-crash.gz (5.6 KB) - added by risto@… 13 years ago.
backtrace without '-v all'

Download all attachments as: .zip

Change History (6)

comment:1 Changed 14 years ago by Isaac Richards

Priority: majorminor
Resolution: invalid
Status: newclosed

comment:2 Changed 13 years ago by risto@…

Resolution: invalid
Status: closedreopened

Hi,

I am also noticing a crash of mythfrontend with 0.19 all the way up to the latest 0.19-fixes branch

here's how to reliably reproduce it -watch live tv -go to epg (hit menu - choose epg) -go up or down a few channels -hit 'X' to change the channel WITHOUT LEAVING the epg

(i have remapped it to 'A' but it shouldn't matter)

  • now if you try to leave the epg mythfrontend crashes :(
  • if you hit up or down it also crashes

let me know if you need more info i have attached backtraces

Changed 13 years ago by risto@…

backtrace run with '-v all'

Changed 13 years ago by risto@…

Attachment: mythtv-0.19-fixes-crash.gz added

backtrace without '-v all'

comment:3 Changed 13 years ago by Isaac Richards

Resolution: invalid
Status: reopenedclosed

Open up a new ticket if you have a new issue. Don't pick some random ticket from over 3 months ago that you think seems similar.

Issue was fixed a couple months ago, regardless.

comment:4 Changed 13 years ago by risto@…

Sorry,

Looks like the fix for this ticket was in http://svn.mythtv.org/trac/changeset/9582

I just applied it the above patch to the 0.19-fixes branch that I had checked out a few days ago and it looks like it works fine.

Please consider applying the fix to 0.19.1 as well

Also, this ticket (#1351) might possibly be a duplicate of #1407 and #1519 since I can confirm that it is fixed by the same changeset

Thanks

Note: See TracTickets for help on using tickets.