Opened 11 months ago

Closed 11 months ago

#13513 closed Bug Report - General (Duplicate)

search.php errors

Reported by: mythtvmike Owned by:
Priority: minor Milestone: 31.0
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In newly upgraded Fedora 30

For mythtv version 30.0-12.20190904git5cde0578d8.fc30

When I search for a program, search fails and I get the errors below on a white screen:

---

Warning at /usr/share/mythweb/modules/tv/search.php, line 347: !NoTrans: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?!!

Warning at /usr/share/mythweb/modules/tv/search.php, line 361: !NoTrans: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?!!

Warning at /usr/share/mythweb/modules/tv/search.php, line 464: !NoTrans: preg_replace(): Compilation failed: invalid range in character class at offset 3!!

Fatal Error at /usr/share/mythweb/classes/Database/Query/mysqlicompat.php, line 98: !NoTrans: SQL Error: Commands out of sync; you can't run this command now #2014!!

datetime: 2019-11-17 17:31:45 (EST) errornum: 256

error type: User Error

error string: !NoTrans: SQL Error: Commands out of sync; you can't run this command now #2014!!

filename: /usr/share/mythweb/classes/Database/Query/mysqlicompat.php

error line: 98

Attachments (1)

mythtv backtrace (28.4 KB) - added by mythtvmike 11 months ago.

Download all attachments as: .zip

Change History (3)

Changed 11 months ago by mythtvmike

Attachment: mythtv backtrace added

comment:1 Changed 11 months ago by mythtvmike

I now see that is report is a duplicate of

#13478: Bug Report - General: mythweb search.php throws errors (new)

... n earlier versions of Fedora, so this may be related to the php-fpm package on Fedora 30: Source RPM : php-7.3.8-1.fc30.src.rpm Build Date : Tue 30 Jul 2019 08:07:57 AM EDT I find that attempting simple searches: curl 'http://localhost/mythweb/tv/search?type=q&s=eleme ... By goldpizza44 — Aug 25, 2019, 3:08:15 PM

where goldpizza44 not only describes the problem, but offers a solution (which works.)

comment:2 Changed 11 months ago by gigem

Milestone: needs_triage31.0
Resolution: Duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.