Opened 7 months ago

Closed 7 months ago

Last modified 6 months ago

#13556 closed Bug Report - General (Won't Fix)

Channel information lost after upgrade from MythTV 29 to 30

Reported by: Jarno Suni Owned by:
Priority: minor Milestone: 31.0
Component: MythTV - General Version: v30-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When I view recordings by frontend it shows strings like "#1024 #1024" where there used to be channel name. New recordings made after upgrade do not have this.

MythTV version 2:30.0+fixes.201912012038.a27754a~ubuntu19.10.1

Change History (7)

comment:1 Changed 7 months ago by Jarno Suni

Upgraded from 2:29.1+fixes.201909121531.4c432df~ubuntu18.04.1 to 2:30.0+fixes.201912012038.a27754a~ubuntu18.04.1

comment:2 Changed 7 months ago by jpilk

Something like this bit me several months ago, and there was some discussion that I can't now find.

It may be a result of Changeset 503218e716 in mythtv from Sep 6, 2018 after deleting and re-establishing a channel list.

chanid: use default of five digits, as that allows more human readability when sources have thousands of channels

comment:3 Changed 7 months ago by Jarno Suni

I think it could be made backwards compatible so that if chanid < 10000 it is handles the old way. That works, if sourceid is 1-9.

comment:4 Changed 7 months ago by Klaas de Waal

Resolution: Won't Fix
Status: newclosed

I agree that this can be the result of 503218e716, most certainly if the old channel list was created before this change and when it affects all channels.

This has been fixed in today's master (pre-v31), not by re-creating the same channel number, but by keeping the deleted channels alive in the twilight zone until there are no recordings anymore that refer to them.

Instead of deleting all channels and creating them again it is usually better to update them. With today's master (pre-v31) the channel numbers of existing channels are not changed.

Given that the problem is already solved your proposed solution will not be implemented and this ticket will be closed.

comment:5 Changed 7 months ago by Jarno Suni

So it won't be fixed in 30 if I understood correctly :(

comment:6 Changed 7 months ago by gigem

MythTV 31 is expected to be released soonish. That will include the fix Klaas described.

comment:7 Changed 6 months ago by Stuart Auchterlonie

Milestone: needs_triage31.0
Note: See TracTickets for help on using tickets.