Opened 13 years ago

Closed 13 years ago

#1381 closed defect (invalid)

Slow keyboard response over network

Reported by: anonymouse Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When running mythfrontent with local X server then keystroke response is reasonably ok. But if running with remote X server then keystroke response is fairly bad (several seconds).

I have strace'd mythfrontend with remote X server and see that the delay always occurs in a select() with varying timeouts (eg. 5.792583, 2.549981, 3.575792, ... secs).

I have no lirc server running, but there doesn't seem to be anywhere to disable it. It is possible that the frontend is repeatedly tryng to contact lircd, but that wouldn't explain why keystroke delay is ok with local X server.

Change History (3)

comment:1 Changed 13 years ago by cpinkham

Resolution: invalid
Status: newclosed

This is an unsupported configuration, and works for me anyway. Use VNC if you want to control a remote mythfrontend.

comment:2 Changed 13 years ago by mythtv@…

Resolution: invalid
Status: closedreopened

But isn't is quite possible that there is some flakey code which is causing keystroke events to only be processed after the select() times out? I very much think so.

I also think it is a bit rich to close a valid ticket without properly considering the validity of the complaint - and to just say it is unsupported. There are plenty of other users with similar problems. And you cannot really just write-off the X-protocol - it was designed specifically to work in the way I am using it.

No wonder MythTV is so bug-ridden.

comment:3 Changed 13 years ago by Dibblah

Resolution: invalid
Status: reopenedclosed

Please feel free to continue to discuss this on the users mailing list. If a developer is interested in fixing this issue for you, it can be migrated to the dev mailing list.

Note: See TracTickets for help on using tickets.