Opened 14 years ago

Closed 14 years ago

#1441 closed defect (worksforme)

SEGFAULT during HouseKeeping

Reported by: trey@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The DVBSignalMonitor::TableMonitorThread? appears to SEGFAULT occationally. When not debugging, I see asserts tripped:

mythbackend: mpeg/atsctables.h:589: SystemTimeTable::SystemTimeTable(const PSIPTable&): Assertion `TableID::STT == TableID()' failed.

and

mythbackend: mpeg/mpegtables.h:401: ProgramAssociationTable::ProgramAssociationTable(const PSIPTable&): Assertion `TableID::PAT == TableID()' failed.

gdb backtrace to follow.

Attachments (2)

gdb-segv.txt.gz (9.0 KB) - added by trey@… 14 years ago.
gdb backtrace
myth.edited.log.gz (1.4 KB) - added by trey@… 14 years ago.
log file associated with trace

Download all attachments as: .zip

Change History (5)

Changed 14 years ago by trey@…

Attachment: gdb-segv.txt.gz added

gdb backtrace

comment:1 Changed 14 years ago by trey@…

This ticket should probably go to danielk, as per his email.

Changed 14 years ago by trey@…

Attachment: myth.edited.log.gz added

log file associated with trace

comment:2 Changed 14 years ago by anonymous

Owner: changed from Isaac Richards to danielk

comment:3 Changed 14 years ago by danielk

Resolution: worksforme
Status: newclosed

I can't reproduce + this may have been fixed by one of the commits in the last couple days.

From the log and backtrace it looks like it ran into trouble printing the PMT for debugging purposes. If this happens again it would be very informative to have the first 200 bytes or so of the data pointed to by the _fullbuffer pointer of the table and the values of the _pesdata and _fullbuffer pointers. This would allow me to parse the packet by hand and figure out where things went wrong.

Note: See TracTickets for help on using tickets.