Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1614 closed defect (fixed)

MythWeb - Recording filenames not URL encoded

Reported by: sphery <mtdean@…> Owned by: xris
Priority: minor Milestone: unknown
Component: mythweb Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

MythWeb does not seem to encode URL's on the Recorded Programs page. Since mythrename.pl makes it easy for users to modify recording filenames, this is now necessary (previously, with the all-numeric filenames, it was never an issue).

The issue was identified by Christophe Zwecker on the lists ( http://www.gossamer-threads.com/lists/mythtv/users/190761#190761 ). He indicated he could not access recordings with German umlauts in their filenames through MythWeb. Although he reported it as an issue with mythrename.pl, I think the issue is actually in MythWeb's not encoding the URL as the filenames with umlauts seem to work with filesystem-based access (i.e. through mythbackend and mythfrontend).

Change History (2)

comment:1 Changed 14 years ago by xris

Resolution: fixed
Status: newclosed

(In [9600]) url encode fix to hopefully close #1614

comment:2 Changed 14 years ago by xris

(In [9610]) missed a couple of links re #1614

Note: See TracTickets for help on using tickets.