Opened 13 years ago

Closed 13 years ago

#1668 closed patch (fixed)

[9669] seqfaults in MpegDescriptor::FindBestMatch()

Reported by: Janne <janne-mythtv@…> Owned by: danielk
Priority: minor Milestone: unknown
Component: dvb Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

FindBestMatch? and FindBestMatches? seems to be broken by design.

Attached patch hopefully changes the functions to the intended behavior.

The patched version seems to work correctly except for broken special characters.

Attachments (1)

9669_fix.patch (1.4 KB) - added by Janne <janne-mythtv@…> 13 years ago.

Download all attachments as: .zip

Change History (2)

Changed 13 years ago by Janne <janne-mythtv@…>

Attachment: 9669_fix.patch added

comment:1 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [9674]) Fixes #1668. References #1035. Fixes copy-n-paste error.

What should have been the index in the loop was copied from another part of the function that used a result of the loop.

Note: See TracTickets for help on using tickets.