Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1751 closed defect (invalid)

mythbackend SEGV when deleting files from mythweb

Reported by: joseph@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: danielk Ticket locked: no

Description

I can reproducabily crash mythbackend by using mythweb to delete a number of files in quick succession.

Version is the latest release-0-19-fixes (rev 9806).

mythtv is configured using: ./configure --compile-type=debug --prefix=/usr/local/myth --enable-dvb --dvb-path=/usr/src/linux-2.6.15/include --disable-joystick-menu --disable-dvb-eit

The host system is a update to date debian sarge install, 2 dvb-t & 1 analogue cards, remote nfs filesystem for /mnt/store, which contains symlinks (mythtv is setup to delete the symlink target as well when deleting a symlink).

I've followed the instructions in http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2, and the extract for the crash shows as:

Thread 12 (Thread -1324663888 (LWP 29487)):
#0  0xb62ff077 in memcpy () from /lib/tls/libc.so.6
No symbol table info available.
#1  0xb6ad5c49 in QString::operator+= () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#2  0xb6ae4e22 in QStringList::join () from /usr/lib/libqt-mt.so.3
No symbol table info available.
#3  0xb705578f in WriteStringList (socket=0x85c3fc8, list=@0xb10b3610) at util.$
        str = {static null = {static null = <same as static member of an alread$
        utf8 = <incomplete type>
        size = -1230148090
        written = -1324666680
        payload = <incomplete type>
        errorcount = 3058273892
        retval = 182
#4  0x0808a0ea in MainServer::SendResponse (this=0x8129ca8, socket=0x85c3fc8, c$
No locals.

I'll attach the full gdb output.

I've tried using valgrind but could not reproduce the problem within. Also tried electric-fence, but this SEGVs on startup.

Please let me know if I help narrow this down.

Attachments (1)

gdb.txt (29.3 KB) - added by joseph@… 13 years ago.
Full output from gdb

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by joseph@…

Attachment: gdb.txt added

Full output from gdb

comment:1 Changed 13 years ago by Joseph Heenan <joseph@…>

Further debugging seems to show that, prior to the crash, gContext->GetHostName?() starts returning wrong values like '435761864' or . I'm still fairly stuck for ideas on how to narrow this down further though.

comment:2 Changed 13 years ago by Isaac Richards

Sounds like memory corruption. Basically need info from valgrind as to what's going on.

comment:3 Changed 13 years ago by Joseph Heenan <joseph@…>

I've run 'valgrind mythbackend' after building with --enable-valgrind, but the problem just won't happen. It seems like it could be a race condition and valgrind alters the timing too much.

Are there any other ways of using valgrind or any other tools I can try?

comment:4 Changed 13 years ago by danielk

Milestone: unknown
Resolution: invalid
Status: newclosed
Version: head

memory corruption + no memory debugging => closed.

The problem could be anywhere so the info in the ticket is not very useful :-|

comment:5 Changed 13 years ago by anonymous

Cc: danielk added

Daniel, I completely understand where you're coming from, and I'd like to try and provide enough information for this to be fixed.

Could you suggest some further debugging that could be carried out, given that valgrind masks the problem?

Note: See TracTickets for help on using tickets.