Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1884 closed patch (fixed)

EIT Guide fixup for comhem

Reported by: torbjorn.jansson@… Owned by: danielk
Priority: minor Milestone: unknown
Component: dvb Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Patch to improve guide fixup for comhem.

  • Adds a few casts in EITHelper::AddEIT()

Without those the guide fixup is not run at all, it should not be needed and i don't understand why but it works.

  • Modifies DBEvent class to insert airdate and originalairdate
  • The guide fixup tries to move as many things as possibel from the description and title to where it should be.

Attachments (2)

comhem-fixup.diff (17.2 KB) - added by torbjorn.jansson@… 13 years ago.
the patch
eitfixup_signness.diff (1.6 KB) - added by Janne <janne-mythtv@…> 13 years ago.

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by torbjorn.jansson@…

Attachment: comhem-fixup.diff added

the patch

comment:1 Changed 13 years ago by Janne <janne-mythtv@…>

The casts in eithelper.cpp are incorrect. The cause of the problem are the numeric constants in init_fixup. They are signed and shouldn't be. I'll attach a patch.

Changed 13 years ago by Janne <janne-mythtv@…>

Attachment: eitfixup_signness.diff added

comment:2 Changed 13 years ago by danielk

(In [10069]) Refs #1884. Fix signedness issue with ComHem? fixup w/patch from Janne.

comment:3 Changed 13 years ago by danielk

(In [10071]) Refs #1884. Adds airdate to EITEvent and loads originalairdate as well so that EIT can fill these in if they are available in the listings data.

comment:4 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [10072]) Fixes #1884. Applies Torbjorn Jansson's updates to the ComHem? EIT data fixup to the EIT branch.

comment:5 Changed 13 years ago by danielk

(In [10238]) Refs #1035. Refs #1728. Refs #1801. Refs #1884. Refs #1615. EIT branch merge.

  • Improves the EIT Fixup functions for the UK and Sweden.
  • Improves the EIT version cache (lowering memory and CPU requirements).
  • Fixes various small memory leaks and lowers memory requirements with earlier deletes.
  • Fixes a spurious error message in filldata with EIT only sources.
Note: See TracTickets for help on using tickets.