Opened 14 years ago

Closed 14 years ago

Last modified 12 years ago

#19 closed defect (fixed)

nvp can be null

Reported by: Anduin Withers <awithers@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The 6712 changes to tv_play.cpp assume nvp is valid for longer than it is. (Basically now the potential to get an AV while tearing down the player exists (and happens)).

Around line 1313 (not exact, the line is "if (GetOSD() && (oset = GetOSD()->GetSet?("status"))"), the problem is that nvp could be gone (due to a state change to kState_None several lines up, which could have already destroyed nvp (the old code would set osd to NULL while tearing it down)).

Change History (1)

comment:1 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [6722]) I believe this fixes #19.

It just adds an "if (nvp)" before the "nvp->GetOSD()" in GetOSD(), and gets rid of some un-needed direct nvp->GetOSD() uses.

Note: See TracTickets for help on using tickets.