Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2006 closed defect (duplicate)

Mythbackend stops recording 02:21 after programme start (DVB)

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.20
Component: dvb Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I don't know if this is a dupe of #1872 (http://svn.mythtv.org/trac/ticket/1872) but "DVBSM(1)::RemovePIDFilter(0x1ffb)" does not appear in the log.

Using SVN, recording BBC Radio 7 (1708) in the UK. All programs stop recording 2mins and 21 secs after programme start This also affects live TV, the stream will stop 2mins and 21 secs after the start of a radio programme (nb not 2:21 after starting LiveTV but 2:21 after programme transition). This makes me think it's something in the stream.

  • Log 1 - recording 03:30 to 04:00 on Radio 7 (fails)
  • Log 2 - recording 01:15 to 01:45 on BBC 4 (TV channel on same multiplex) (succeeds) and 01:30 to 02:00 on Radio 7 (fails)

Any more information I can add?

Attachments (6)

mythbackend.failed_1708_0330to0400.log (23.6 KB) - added by anonymous 13 years ago.
Log 1
mythbackend.failed_1708_0130to0200.suceeded_1009_0115to0145.log.gz (49.5 KB) - added by anonymous 13 years ago.
Log 2
2006-dbg.patch (3.0 KB) - added by danielk 13 years ago.
debugging patch
2006-dbg-v2.patch (3.0 KB) - added by danielk 13 years ago.
updated version of patch
mythbackend.failed-1200to1230-1708.log.gz (29.3 KB) - added by anonymous 13 years ago.
bbc7.patch.txt (1.7 KB) - added by dm@… 13 years ago.

Download all attachments as: .zip

Change History (13)

Changed 13 years ago by anonymous

Log 1

Changed 13 years ago by anonymous

Log 2

comment:1 Changed 13 years ago by anonymous

Definitely something in the stream 'Start recording 2 mins early' has produced a 4:28 recording. The status screen shows the tuner to still be in use, but if I watch the recording (it's not finished yet), the length is a constant 4:28

comment:2 Changed 13 years ago by danielk

Component: mythtvdvb
Milestone: 0.20
Owner: changed from Isaac Richards to danielk
Version: head

Changed 13 years ago by danielk

Attachment: 2006-dbg.patch added

debugging patch

comment:3 Changed 13 years ago by danielk

Anon, can you attach a log w/"-v record" with the attached patch applied?

It looks like AdjustFilters?() never finishes it's job. The debugging patch should narrow down where it gets stuck.

Changed 13 years ago by danielk

Attachment: 2006-dbg-v2.patch added

updated version of patch

Changed 13 years ago by anonymous

comment:4 Changed 13 years ago by anonymous

Thanks for the response - logfile is attached, trying to record BBC7 12:00 to 12:30 today. It's left a 2:21 recording as usual. The file's quite big as it's full of: AddTSPacket: Out of sync!!! Need to wait for next payloadStart

Which started appearing last night - possibly another case of #1888 as I'm also getting the 'Guide data until 2037-12-06 13:23' bug

comment:5 Changed 13 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of #1981.

Anon, it looks like we die shutting down the fake video stream. This is also the suspected problem with the earlier #1981 ticket, so I will follow up there.

Changed 13 years ago by dm@…

Attachment: bbc7.patch.txt added

comment:6 Changed 13 years ago by dm@…

I've looked at this and the attached patch seems to work for me. I've made several recordings now off BBC7.

It seems that this problem only occurs with BBC7 and is something to do with them sending a new PMT at the beginning of each programme. The major bug was a deadlock that can occur if the dummy video thread is in the process of writing when AdjustFilters? is called. The thread acquires _pid_lock whenever it writes a packet but AdjustFilters? holds this lock. That means that StopDummyVideo? may not complete. Moving the call to before AdjustFilters? takes the lock fixes this.

There were two other things that I've included in this patch: both very minor. It seems that sometimes the frontend stops at the beginning of a programme when listening to live radio and I suspect that this is related to the new PMT and restarting the dummy video thread. The two changes I've made seem to improve this. Also I noticed when I played the test recordings of BBC7 that the logo and programme information weren't being displayed. My previous patch to fix a bug in the interactive TV had inadvertently turned off MHEG in recordings. This fixes that.

David.

comment:7 Changed 13 years ago by danielk

(In [10457]) Fixes #1981. Refs #2006. Applies David Matthews' patch for deadlock in DVBRadio & UK Interactive TV when the PIDs change.

Note: See TracTickets for help on using tickets.