Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2041 closed defect (worksforme)

LiveTV tuning broken for IVTV tuner between [10390] and [10402]

Reported by: g8ecj@… Owned by: Isaac Richards
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Running [10390] on both master & slave back/frontends I can browse channels in LiveTV and select them.

In [10402] browsing is OK but on pressing 'Enter' the OSD changes from the program details to 'UNKNOWN' and no channel change takes place.

Tried turning off Browse mode - no difference, still no channel change.

Not tested with scheduled recording.

Running [10390] slave backend with [10402] frontend (on master box) works OK as well (backend problem?)

What logs are required?

Change History (2)

comment:1 Changed 13 years ago by danielk

Resolution: worksforme
Status: newclosed

Cannot reproduce with [10455].

comment:2 Changed 13 years ago by danielk

(In [10465]) Refs #1966. Refs #2041. Fix channel flipping when not in browse mode.

The channel flipping code depended on GetNextChannel?() looking up the current channel when no channel was provided. The new implementation of GetNextChannel?() was not checking for this condition so it always fellback to changing channels with respect to the first channel in the lineup.

Note: See TracTickets for help on using tickets.