Opened 13 years ago

Closed 13 years ago

#2103 closed defect (fixed)

mythfill doesn't let allow channel updates for firewire from Datadirect

Reported by: gdragon at jetcom dt org Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Mythfilldatabase does not let firewire imputs fetch the channel listings. I believe this is due to the auto-reconciliation of channels from digital sources with DD. I don't think this is intended behavior.

It ends up adding all the datadirect selected inputs only to delete them right after because they haven't been scanned.

I think the responsible code is right here: in filldata.cpp

        insert_channels = (SourceUtil::IsAnalog(source.id) &&
                           !remove_new_channels);

 int new_channels = DataDirectProcessor::UpdateChannelsSafe(
        source.id, insert_channels);

It doesn't think the source is Analog, because well, it's not. There just is no good way to scan channels.

Note: using --do-channel-updates solves the problemi'm not sure it's the proper solution, and also the "Fetch channels" button in the setup does no do this option, so it's a bit klunky.

Change History (3)

comment:1 Changed 13 years ago by danielk

Milestone: 0.20
Version: head

comment:2 Changed 13 years ago by danielk

A patch for this is available in ticket #2084.

comment:3 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [10698]) Fixes #2084. Fixes #2103. Fixes some mythfilldatabase problems with respect to inserting channels.

For #2084, this passes the cardtype in to mythfilldatabase when it is called from withing mythtv-setup, this is needed because at this point the connection between the card input and the source has not yet been saved to the database if the user has changed the source since entering the configuration pane. This also prevents mythfilldatabase from running in mythtv-setup for scan required sources if there are no channels in the lineup. This is not strictly needed after the fix, but it prevents us from wasting time doing this and making the UI unresponsive in the meantime.

For #2103, this creates a new class of DTV devices for Firewire and DBOX2, "unscanable" devices, this is for devices which should be scanned but we do not yet have the code to scan them.

Note: See TracTickets for help on using tickets.