Opened 13 years ago

Closed 13 years ago

#2235 closed defect (worksforme)

No channels were detected.

Reported by: dhighley@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I'm trying to bring up a new installation of mythtv using svn head. Everything seems to build and install correctly. But after running mythfilldatabase there are no channel listings. I checked the mythbackend log and find no apparent errors. The log indicates that it checked the database and found no listings for each day.

I do have the head version working on another system, but it was an update to working installation. I have dropped the database and re-ran the setup several times. I have also ran svn update on mythtv, mythplugins, and myththemes for the last few days. I then do a make clean and make.

Both systems are AMD 64 bit Fedora core 5 systems. The one not working is a dual Opteron. Both systems are kept up to date with Fedora updates.

Change History (10)

comment:1 Changed 13 years ago by Isaac Richards

Priority: blockerminor
Severity: highmedium

comment:2 Changed 13 years ago by stuartm

Resolution: invalid
Status: newclosed

This sounds like a configuration issue, you'll need to check a few things and we'll need some more details.

  • How were the channels inserted, from a scan, channels.conf import or mythfilldatabase itself?
  • Which grabber are you using?
  • Is it defined in mythtv-setup?
  • If an xmltv grabber is used have you created the channel list for the grabber in the .mythtv directory?
  • Have you defined the xmltvid ids for the channels?

You'll also need to attach the section of the log from the mythfilldatabase run.

Re-open the ticket when you can answer those questions and provide the log.

comment:3 Changed 13 years ago by dhighley@…

Resolution: invalid
Status: closedreopened

Channels are set up via xmltv and the zap2 site. Use the same grabber on both systems for North America and the same account. I do not define any xmltvid ids for the channels. When I create the database I use the mc.sql script that comes in the mythtv tree of code. When I compare using the new web page the set up settings I do see quite a few differences between the new database and the one initially defined using mythtv 0.19, but I believe that would be expected. Sorry for being light on information to start.

The only whine in the myth set up is about channel 3 not existing. Which for a new system would always be true as you have not filled the database yet. I think that would confuse a new user.

Mythbackend log: QDateTime::fromString: Parameter out of range QDateTime::fromString: Parameter out of range 2006-08-23 21:18:52.488 Using runtime prefix = /usr/local 2006-08-23 21:18:52.539 New DB connection, total: 1 2006-08-23 21:18:52.544 Connected to database 'mythconverg' at host: localhost 2006-08-23 21:18:52.547 Current Schema Version: 1155 Starting up as the master server. 2006-08-23 21:18:52.550 New DB connection, total: 2 2006-08-23 21:18:52.551 Connected to database 'mythconverg' at host: localhost 2006-08-23 21:18:52.552 EITHelper: localtime offset -7:00:00 2006-08-23 21:18:52.565 TVRec(1) Error: Problem finding starting channel, settin g to default of '3'. 2006-08-23 21:18:52.567 New DB connection, total: 3 2006-08-23 21:18:52.567 Connected to database 'mythconverg' at host: localhost 2006-08-23 21:18:52.569 Channel(/dev/video1): SetInputAndFormat?() failed 2006-08-23 21:18:52.570 TVRec(1) Error: Setting start channel '3' failed,

and no other channels were found on input.

2006-08-23 21:18:52.574 New DB scheduler connection 2006-08-23 21:18:52.575 Connected to database 'mythconverg' at host: localhost 2006-08-23 21:18:52.595 Main::Starting HttpServer?

========================================================= mythfilldatabase output: 2006-08-24 07:01:10.763 Using runtime prefix = /usr/local 2006-08-24 07:01:10.779 New DB connection, total: 1 2006-08-24 07:01:10.783 Connected to database 'mythconverg' at host: 127.0.0.1 2006-08-24 07:01:10.786 New DB connection, total: 2 2006-08-24 07:01:10.786 Connected to database 'mythconverg' at host: 127.0.0.1 2006-08-24 07:01:10.786 Updating source #1 (cable) with grabber datadirect 2006-08-24 07:01:10.787 2006-08-24 07:01:10.787 Checking day @ offset 0, date: Thu Aug 24 2006 2006-08-24 07:01:10.787 Data refresh needed because no data exists for day @ off set 0 from 6PM - midnight. 2006-08-24 07:01:10.787 Refreshing data for Thu Aug 24 2006 2006-08-24 07:01:10.787 New DB DataDirect? connection 2006-08-24 07:01:10.788 Connected to database 'mythconverg' at host: 127.0.0.1 2006-08-24 07:01:10.788 Retrieving datadirect data. 2006-08-24 07:01:10.788 Grabbing data for Thu Aug 24 2006 offset 0 2006-08-24 07:01:10.788 From Thu Aug 24 07:00:00 2006 to Fri Aug 25 07:00:00 200 6 (UTC) 2006-08-24 07:01:10.788 Grabbing listing data --07:01:10-- http://datadirect.webservices.zap2it.com/tvlistings/xtvdService

=> `-'

Resolving datadirect.webservices.zap2it.com... 206.18.98.160 Connecting to datadirect.webservices.zap2it.com|206.18.98.160|:80... connected. HTTP request sent, awaiting response... 401 Unauthorized Connecting to datadirect.webservices.zap2it.com|206.18.98.160|:80... connected. HTTP request sent, awaiting response... 200 OK Length: unspecified [text/xml]

0K .......... .......... .......... .......... .......... 12.69 KB/s

50K .......... .......... .......... .......... .......... 86.86 KB/s

100K .......... .......... .......... .......... .......... 52.07 KB/s 150K .......... .......... .... 126.04 KB/s

07:01:20 (30.70 KB/s) - `-' saved [178180]

2006-08-24 07:01:20.820 DataDirect?: Your subscription expires on 09/27/2006 11:1 6:59 PM 2006-08-24 07:01:20.850 New DB connection, total: 3 2006-08-24 07:01:20.851 Connected to database 'mythconverg' at host: 127.0.0.1 2006-08-24 07:01:23.601 Grab complete. Actual data from Thu Aug 24 07:00:00 200 6 to Fri Aug 25 07:00:00 2006 (UTC) 2006-08-24 07:01:23.602 Main temp tables populated. 2006-08-24 07:01:23.602 Updating myth channels. 2006-08-24 07:01:23.604 Updating icons for sourceid: 1 2006-08-24 07:01:23.604 Channels updated. 2006-08-24 07:01:23.608 Did not find any new program data. 2006-08-24 07:01:23.608 2006-08-24 07:01:23.608 Checking day @ offset 1, date: Fri Aug 25 2006 2006-08-24 07:01:23.608 Refreshing data for Fri Aug 25 2006 2006-08-24 07:01:23.609 Retrieving datadirect data. 2006-08-24 07:01:23.609 Grabbing data for Thu Aug 24 2006 offset 1 2006-08-24 07:01:23.609 From Fri Aug 25 07:00:00 2006 to Sat Aug 26 07:00:00 200 6 (UTC) 2006-08-24 07:01:23.609 Grabbing listing data --07:01:23-- http://datadirect.webservices.zap2it.com/tvlistings/xtvdService

=> `-'

Resolving datadirect.webservices.zap2it.com... 206.18.98.160 Connecting to datadirect.webservices.zap2it.com|206.18.98.160|:80... connected. HTTP request sent, awaiting response... 401 Unauthorized Connecting to datadirect.webservices.zap2it.com|206.18.98.160|:80... connected. HTTP request sent, awaiting response... 200 OK Length: unspecified [text/xml]

0K .......... .......... .......... .......... .......... 12.40 KB/s

50K .......... .......... .......... .......... .......... 76.69 KB/s

comment:4 Changed 13 years ago by danielk

Version: head

Is this a digital source? QAM?

In that case you _need_ to scan for channels, mythfilldatabase will not add any channels since they would be untunable.

You can run the scan from the input connections pane, you can also run mythfilldatabase with options to just add channels from that same pane (which is quicker than running it on the command line with no options).

comment:5 Changed 13 years ago by dhighley@…

No, this is a PVR 500 card with the latest ivtv driver. I did run xmltv separately to verify that it actually down loads the listings. I'm running the latest xmltv, ?5.44.

David Highley

comment:6 Changed 13 years ago by dhighey@…

And, just to verify, you do realize that you should be using mythtv-setup, and not using XMLTV directly, to set up channels in MythTV for North American sources, right?

Mike

Yes, I know that you use myth-setup and not xmltv directly and yes the backend runs an update based on the zap2 suggested schedule. All that is working, just nothing is going into the database for listings. I do have another system that works. Like I said, the difference is I wanted to start clean so I dropped the database to start completely from ground zero.

David Highley

comment:7 Changed 13 years ago by dhighley@…

I have updated to svn 11015 and done the following. I unloaded a myth database from another system, edited, and loaded that database. I then ran setup to drop and add the right tuner cards. Did a mythtfilldatabase and it worked. Then I used the web page to delete all channels, followed by another mythfilldatabase and it worked. It looks like it has to do with the starting from a clean system with no database.

comment:8 Changed 13 years ago by Isaac Richards

Resolution: worksforme
Status: reopenedclosed

Can't reproduce with a clean install.

comment:9 Changed 13 years ago by dhighley@…

Resolution: worksforme
Status: closedreopened

Did you test on a 64 bit installation?

comment:10 Changed 13 years ago by Isaac Richards

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.