Opened 14 years ago

Closed 11 years ago

#2617 closed task (fixed)

hybrid analogue/digital tuner support

Reported by: Simon Kenyon Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Add support for the various hybrid analogue/digital tuners available.

My device is a terratec cinergy hybrid T XS.

Here is the information requested by Daniel so he can add support:

2006-10-25 16:12:54.972 DVBChan(0): Using DVB card 0, with frontend 'Zarlink ZL10353 DVB-T'.

Probed info: Terratec Hybrid XS [em28xx]

Attachments (3)

2617-v1.patch (1.2 KB) - added by danielk 14 years ago.
Patch for Zarlink ZL10353 and WinTV HVR 900 M/R: 65008/A1C0
Hybrid_tda10046_support.patch (673 bytes) - added by anonymous 13 years ago.
TDA10046h support
nexus-hybrid.diff (741 bytes) - added by jose.bandos@… 13 years ago.
Support for Hauppauge Nexus CA/Technotrend TT-2300C DVB-C Hybrid

Download all attachments as: .zip

Change History (18)

comment:1 Changed 14 years ago by Simon Kenyon

further info based on information posted on http://linuxtv.org/v4lwiki/index.php/Em2880

extrapolating from the kernel logs from my device and the text shown in the "Probed info:" field and using the kernel logs on the web site indicate that people have the following devices:

Hauppauge WinTV HVR 900

Terratec Hybrid XS

Terratec Hybrid XS Secam

Terratec Cinergy T XS

Terratec Cinergy T XS (new/MT2060)

Compro, VideoMate? U3

Pinnacle Hybrid Pro

Leadtek Winfast USB II

Hauppauge WinTV HVR Rev. 2

Pinnacle PCTV DVB-T

MSI DigiVox? A/D

the same web site reports that the driver supports the following devices:

in progress:

Kworld 355 U DVB-T

Compro VideoMate? U3

Hauppauge HVR 900 M/R: 65018/B2C0 (Sticker on the device, only analogue TV is supported at the moment)

currently supported DVB-T/Hybrid devices:

Kworld 350 U DVB-T

MSI DigiVox? A/D (USB2.0)

Hauppauge WinTV HVR 900 M/R: 65008/A1C0

Terratec Cinergy Hybrid T XS - ZL10353

Terratec Cinergy Hybrid T XS - MT352

Terratec Cinergy Hybrid T XS France

Terratec Prodigy Hybrid T XS

Terratec Cinergy T XS - xc3028

Terratec Cinergy T XS - mt2060

Pinnacle PCTV USB Stick

DNT DA2 Hybrid

Pinnacle PCTV Hybrid Pro Stick

Empire USB 2.0 Pen Dual TV

BestBuy? Easy TV USB hybrid (EB1A:2881)

currently not supported (but possible):

iDream DVB-T & Analog USB TV Tuner

unfortunately, the above list is not exact enough to rely on.

the frontends that i've found are:

Zarlink ZL10353 DVB-T

Zarlink MT352 DVB-T

comment:2 Changed 14 years ago by danielk

Owner: changed from Isaac Richards to danielk

comment:3 Changed 14 years ago by support@…

Ok i'm testing the Hauppauge WinTV HVR 900 M/R: 65008/A1C0 card which works well as two seperate devices. The problem is it confuses the scheduler. It assumes you have two tuners when infact you only have one. I can have a machine with a single USB device and schedule two programs, one on DVB-T and one on analogue. The result is I only get one program and the backend gets a little confused.

Any way to pair seperate tuners to indicate that they are a single device and cannot be shared?

Running 0.20-fixes branch on a 2.6.15 kernel with a recent build of the v4l-dvb code.

comment:4 Changed 14 years ago by support@…

Futher update based on your requests on the mailing list I ran the backend with "-v recording" and got the following output

2006-11-20 22:28:16.125 DVBChan(0): Using DVB card 0, with frontend 'Zarlink ZL10353 DVB-T'.
2006-11-20 22:28:23.875 DVBChan(0): Using DVB card 0, with frontend 'Zarlink ZL10353 DVB-T'.

Now if I switch to Live TV it brings up the analogue tuner which kills the DVB-T recording.

All we really need is a sensible way to pair up devices that can't be used simultaneously.

Changed 14 years ago by danielk

Attachment: 2617-v1.patch added

Patch for Zarlink ZL10353 and WinTV HVR 900 M/R: 65008/A1C0

comment:5 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [12244]) Fixes #2617. Adds analog support for two hybrid DVB-T/PAL cards with help from Simon Kenyon.

comment:6 Changed 14 years ago by Simon Kenyon

Resolution: fixed
Status: closedreopened

The analog option appear is the configuration screen, but I am still having problems. This is what i have discovered this evening. Digital scanning works fine, analog does not. When i turned on full logging in mythtv-setup this is what I saw:

When it tries to find the device to use for the analogue scan it prints out:

SELECT videodevice FROM capturecard, cardinput WHERE inputname = 'Television' AND cardinput.cardid = 6 AND ( ( cardinput.childcardid != '0' AND cardinput.childcardid = capturecard.cardid ) OR ( cardinput.childcardid = '0' AND cardinput.cardid = capturecard.cardid ) )

and then says that there is no device. This is because the select returns the empty set.

Digging further into the database and dumping the rows from capturecard and cardinput I see:

INSERT INTO capturecard VALUES (6,'/dev/v4l/video0','/dev/dsp','/dev/v4l/vbi0','V4L','Television',0,'cozumel',0,0,1,0,0,NULL,0,2,0,NULL,0,31338,80,NULL,1000,3000,5,0,0,0,0,0,NULL); INSERT INTO capturecard VALUES (5,'0',,,'DVB','DVBInput',NULL,'cozumel',0,0,1,0,0,NULL,0,2,0,NULL,0,31338,80,NULL,500,3000,0,0,0,0,0,0,0);

INSERT INTO cardinput VALUES (7,5,2,'Television',,0,'N',,'55',1,NULL,NULL,11700000,10600000,9750000,,1,6,0,0); INSERT INTO cardinput VALUES (6,5,1,'DVBInput',NULL,0,'N',NULL,'1',1,NULL,NULL,11700000,10600000,9750000,'Digital',1,0,0,0);

which maybe explains why there is no device to scan. I will clean out the database completely tonight and start again, to see if the previous "partial" support has somehow messed up the db.

comment:7 Changed 14 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [12497]) Fixes #2617. Fixes scanning of analog portion of hybrid digital+analog cards.

This was caused by a bug in the InputSelector::load() query which wasn't getting the parentid properly on child cards, instead it returned the childid.

comment:8 Changed 13 years ago by JerryG

Resolution: fixed
Status: closedreopened

Please add support for ASUSTeK MyCinema? P7131 Hybrid card.

DVB frontend: 'Philips TDA10046H DVB-T'
V4L name: 'ASUSTeK P7131 Dual [saa7134]'

Seems that modifying videosource.cpp

- short_name.lower() == "wintv hvr 900 m/r: 65008/a1c0");

to

+ short_name.lower() == "wintv hvr 900 m/r: 65008/a1c0") ||
+ short_name.left(17).lower() == "philips tda10046h");

does the job. Thanks!

Changed 13 years ago by anonymous

TDA10046h support

comment:9 Changed 13 years ago by danielk

Resolution: fixed
Status: reopenedclosed

(In [13148]) Fixes #2617. Adds support for ASUSTeK MyCinema?? P7131 Hybrid card with patch from JerryG.

Changed 13 years ago by jose.bandos@…

Attachment: nexus-hybrid.diff added

Support for Hauppauge Nexus CA/Technotrend TT-2300C DVB-C Hybrid

comment:10 Changed 13 years ago by jose.bandos@…

Resolution: fixed
Status: closedreopened

I've attached a patch which adds support for the Nexus CA/TT-2300C dvb-c card. The low level support for the analog part of this card is being added into v4l-dvb, and already allows analog tuning.

comment:11 Changed 13 years ago by paul@…

Any chance you can add support for digitalnow DNTV Live! DVB-T Pro ( Zarlink MT352 DVB-T)? ie this is another Hybrid tunner with composite input + FM radio etc..

comment:12 Changed 13 years ago by Janne Grunau

Owner: changed from danielk to Janne Grunau
Status: reopenednew
Version: 0.20head

comment:13 Changed 13 years ago by danielk

Owner: changed from Janne Grunau to danielk

Janne, I'm taking this ticket back...

I'd like to base a comprehensive solution on Input Groups, and I need to look at this code anyway to check whether the Input Groups code broke hybrid cards.

comment:14 Changed 12 years ago by Dibblah

Status: newassigned

comment:15 Changed 11 years ago by danielk

Resolution: fixed
Status: assignedclosed

This is handled by input groups these days.

Note: See TracTickets for help on using tickets.