Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#275 closed defect (invalid)

record suppressed because of insane file size predection

Reported by: tino.keitel@… Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hi,

my backend just refused to start a recording with this message:

2005-08-29 22:08:40.315 AutoExpire?: Found 1 recorders w/max rate of 138 MiB/min

2005-08-29 22:08:40.316 AutoExpire?: space: 2.0 GB w/freq: 10 min

2005-08-29 22:08:42.303 Reschedule requested for id -1.

2005-08-29 22:08:43.005 Scheduled 1 items in 0.7 = 0.67 match + 0.04 place

2005-08-29 22:08:43.009 Recording starts soon, AUTO-Startup assumed

2005-08-29 22:08:43.011 Estimated program length: 150 minutes, size: 26017 MB, free space: 14484 MB

2005-08-29 22:08:43.011 SUPPRESSED recording 'Eyes Wide Shut' on channel 1008 on cardid 1, sourceid 1. Only 14484 Megs of disk space available.

What's wrong here? This is an ordinary DVB-T budget card (WinTV Nova-T) and the channel should not have more than 5 MBit/s.

Change History (4)

comment:1 Changed 14 years ago by Isaac Richards

Owner: changed from Isaac Richards to danielk

comment:2 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed

You need to enable AutoExpire?.

The file size prediction is working as intended for HDTV capable sources.

19400000 /* bits per second */ / 8 /* bits in byte */ * 60 /* seconds in minute */ * 150 /* minutes in recording */ * 1.25 /* 25% safety */ = 25 GB

Recordings shouldn't be suppressed because of this unless AutoExpire? is disabled. There is no way for MythTV to know the channel transmits at just 5000000 bps. You are welcome to improve GetMaxBitrate?() to take previous recordings on the channel into account.

comment:3 Changed 14 years ago by tino.keitel@…

AutoExpire? is disabled.

What happens if I enable AutoExpire?? The record won't be suppressed but no other recordings will be deleted? Or will it delete recordings until 26 GB are free?

comment:4 Changed 14 years ago by danielk

In your case, it will free space until there are 2GB free every ten minutes.

2005-08-29 22:08:40.316 AutoExpire?: space: 2.0 GB w/freq: 10 min

Note: See TracTickets for help on using tickets.