Opened 13 years ago

Closed 13 years ago

#2814 closed defect (fixed)

mp3 file causes lockup while scanning for new music

Reported by: andrew.lyon@… Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythmusic Version: head
Severity: medium Keywords: 12169 lockup scanning new music with attached mp3
Cc: Ticket locked: no

Description

Hi,

the attached mp3 causes mythtv svn 12169 to hang on the updating database phase of scanning for new music, no errors are logged even with -l audio, but I was able to narrow it down to this file by using lsof to find which file mythfrontend had open at the time.

I cannot see anything wrong with the file myself, id3info and mp3info both return valid data.

Andy

Attachments (4)

trace (2.1 KB) - added by myth@… 13 years ago.
trace of the hung thread
fix1.patch (652 bytes) - added by myth@… 13 years ago.
one possible fix
fix2.patch (1.1 KB) - added by myth@… 13 years ago.
another possible (probably better) fix.
fix3.patch (1.3 KB) - added by myth@… 13 years ago.
fixed patched

Download all attachments as: .zip

Change History (9)

comment:1 Changed 13 years ago by andrew.lyon@…

the mp3 is too big to attach, can you give me somwhere to upload it ?

thanks andy

comment:2 Changed 13 years ago by andrew.lyon@…

Hi,

I have uploaded the file to rapidshre, you should be able to get it from http://rapidshare.com/files/8036192/dave_angel-the_essential_mix-part_1-ms.mp3

andy

comment:3 Changed 13 years ago by myth@…

I can reproduce this, I'll take a stab at fixing it. But the file also seems to be corrupt, at least nothing I have can play it (guess that's also why locks up mythmusic). It's md5sum is ae6ee2b6c945516e4b7f34c9252446ec, is that correct ?

Changed 13 years ago by myth@…

Attachment: trace added

trace of the hung thread

Changed 13 years ago by myth@…

Attachment: fix1.patch added

one possible fix

Changed 13 years ago by myth@…

Attachment: fix2.patch added

another possible (probably better) fix.

comment:4 Changed 13 years ago by myth@…

I've attached two fixes. I'm not sure about the first, might fail on legal files, although I doubt. The second is inspired by this email which describes the same problem, of course since we're not using mmap, we could fail twice in a row and the buffers could just happen to be in the same position ?

Changed 13 years ago by myth@…

Attachment: fix3.patch added

fixed patched

comment:5 Changed 13 years ago by stuartm

Milestone: unknown0.21
Resolution: fixed
Status: newclosed

This has probably been fixed by the switch to taglib. Re-open if you are able to reproduce with svn head.

Note: See TracTickets for help on using tickets.