Opened 13 years ago

Closed 13 years ago

#2858 closed defect (duplicate)

Backend crashing TVRec

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: unknown
Component: dvb Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description


Attachments (2)

gdb.txt (42.7 KB) - added by anonymous 13 years ago.
gdb.2.txt (120.4 KB) - added by anonymous 13 years ago.

Download all attachments as: .zip

Change History (12)

Changed 13 years ago by anonymous

Attachment: gdb.txt added

comment:1 Changed 13 years ago by anonymous

2006-12-31 06:51:36.881 Discarding broken PES packet 2006-12-31 06:51:36.904 PESPacket: Failed CRC check 0xffffffff != 0x1291273f for StreamID = 0x72 2006-12-31 06:51:36.905 PESPacket: Failed CRC check 0xffffffff != 0x1291273f for StreamID = 0x72 2006-12-31 06:51:36.925 PESPacket: Failed CRC check 0xffffffff != 0x1291273f for StreamID = 0x72 2006-12-31 06:51:36.926 Discarding broken PES packet 2006-12-31 06:51:36.934 EITScanner: Added 157 EIT Events 2006-12-31 06:51:36.935 TVRec(1): SetChannel?() -- begin 2006-12-31 06:51:36.936 TVRec(1): ClearFlags?(RingBufferReady?,) -> RunMainLoop?,SignalMonitorRunning?,EITScannerRunning, 2006-12-31 06:51:36.936 TVRec(1): Request: Program(no) channel(50146) input() flags(EITScan,) 2006-12-31 06:51:36.938 ChannelBase?(1): Failed to find channel(50146) on current input (DVBInput #1) of card (1). 2006-12-31 06:51:36.940 ChannelBase?(1): Found channel(50146) on another input (DVBInput #2) of card (1). 2006-12-31 06:51:36.940 TVRec(1): HW Tuner: 1->1 2006-12-31 06:51:36.941 TVRec(1): TeardownSignalMonitor?() -- begin

comment:2 Changed 13 years ago by anonymous

Summary: Backend crashing while parsing EITBackend crashing TVRec

Changed 13 years ago by anonymous

Attachment: gdb.2.txt added

comment:3 Changed 13 years ago by danielk

Component: mythtvdvb
Owner: changed from Isaac Richards to danielk

Can you try the patch attached to #2664.... I think this may be a duplicate of that ticket, but I'm not sure yet.

comment:4 Changed 13 years ago by anonymous

I have patched it... and gdb is running again.... will see....

comment:5 Changed 13 years ago by anonymous

I can't get signal lock after installing this patch...

this is output I'm getting for ATSC FusionHDTV 5 Lite

2007-01-02 17:18:21.349 TVRec(3): Changing from None to WatchingLiveTV 2007-01-02 17:18:21.350 TVRec(3): HW Tuner: 3->3 2007-01-02 17:18:21.352 DVBChan(2) Warning: Symbol Rate setting (0) is out of range (min/max:5056941/10762000)

comment:6 Changed 13 years ago by danielk

Resolution: fixed
Status: newclosed

(In [12383]) Fixes #2858. Refs #2147. Reverts [11334], this threw away a possibly good TS packet if it followed a lost TS packet.

comment:7 Changed 13 years ago by anonymous

Resolution: fixed
Status: closedreopened

I don't think it's a fix by any means... as this issue in .20-fixes branch and

that's the way dvbrecorder.cpp looks like

{

if (!info->CheckCC(tspacket.ContinuityCounter?())) {

VERBOSE(VB_RECORD, LOC +

QString("PID 0x%1 discontinuity detected").arg(pid,0,16));

_continuity_error_count++;

}

}

comment:8 Changed 13 years ago by danielk

Sorry, that commit should referenced #2863 as fixed, not this ticket..

comment:9 Changed 13 years ago by anonymous

danielk,

Is there any idea why I don't get signal lock with 2664 patch?

-p

comment:10 in reply to:  9 Changed 13 years ago by Janne Grunau

Resolution: duplicate
Status: reopenedclosed

Replying to anonymous:

Is there any idea why I don't get signal lock with 2664 patch?

The patch was unfortunately not correct. Try again with [12480] and reopen the ticket if you can reproduce the error. I close it as duplicate of #2664

Note: See TracTickets for help on using tickets.