Opened 13 years ago

Closed 9 years ago

#2919 closed defect (invalid)

Oldrecorded and recorded entries do not match when preroll used

Reported by: red321 Owned by: sphery
Priority: minor Milestone: unknown
Component: Contributed Scripts & Apps Version: 0.20
Severity: medium Keywords: preroll myth.rebuilddatabase
Cc: Ticket locked: no

Description

When preroll is set, oldrecorded.startime is the programme start, and recorded.starttime and the filename is the recording starttime including preroll. When myth.rebuilddatabase searches oldrecorded for title and description, it fails as the filename and oldrecorded don't match.

Change History (6)

comment:1 in reply to:  description Changed 12 years ago by anonymous

Replying to red321:

When preroll is set, oldrecorded.startime is the programme start, and recorded.starttime and the filename is the recording starttime including preroll. When myth.rebuilddatabase searches oldrecorded for title and description, it fails as the filename and oldrecorded don't match.time

When I re-read this I realised it wasn't very well explained.

The problem is that myth.rebuilddatabase uses the orphan files filename to rebuild the database entry. The orphaned filename is by default chanid_(starttime+prerolloffset).mpg. The chanid and (starttime+prerolloffset) are used to find entries in oldrecorded. However as oldrecorded is populated with chanid and starttime (without preroll), unless preroll is 0, then there are no matches.

The solution is either to use startime for all entries (filename, recorded, oldrecorded) or always use actual startime which includes preroll.

comment:2 Changed 12 years ago by stuartm

Owner: changed from Isaac Richards to stuartm

comment:3 Changed 12 years ago by stuartm

Component: mythtvcontrib
Owner: changed from stuartm to Isaac Richards

comment:4 Changed 12 years ago by stuartm

This is a problem with myth.rebuilddatabase.pl and it needs to be fixed there.

The mixing of starttime/restartts/progstart etc is a regrettable source of confusion, but the changes required to fix it would be far harder than just working around it this in the script.

comment:5 Changed 10 years ago by stuartm

Component: contribContributed Scripts & Apps
Owner: changed from Isaac Richards to sphery
Status: newassigned

comment:6 Changed 9 years ago by sphery

Resolution: invalid
Status: assignedclosed

Feature request without patch.

FWIW, the myth.rebuilddatabase.pl script will be obsoleted as soon as I've added its functionality to mythbackend and mythfrontend. I plan to do this after the 0.23 release.

Note: See TracTickets for help on using tickets.