Opened 13 years ago

Closed 13 years ago

#2952 closed defect (fixed)

DVD Loops when playing The Illusionist

Reported by: luitjens@… Owned by: skamithi
Priority: minor Milestone: unknown
Component: mythdvd Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When starting the dvd 'The Illusionist' the dvd loops at the main logo after telling the movie to play from the root menu.

To reproduce:

Put 'The Illusionist' dvd into the mythtv dvd player.

Go to 'Optical Disk'

Go to 'Play Dvd'

Go to the root menu.

Select 'Play Film'

The first logo that comes up will loop forever.

Below is the output from mythfrontend --verbose all from what I believe to be the offending area:

2007-01-20 00:17:36.714 AO: Broadcasting free space avail
2007-01-20 00:17:36.717 AO: Broadcasting free space avail
2007-01-20 00:17:36.723 AO: Broadcasting free space avail
2007-01-20 00:17:36.728 AO: Broadcasting free space avail
2007-01-20 00:17:36.728 NVP: ClearAfterSeek(1)
2007-01-20 00:17:36.728 VideoOutputXv: ClearAfterSeek()
2007-01-20 00:17:36.728 VideoOutputXv: DiscardFrames(0)
2007-01-20 00:17:36.728 VideoBuffers::DiscardFrames(0): AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
2007-01-20 00:17:36.728 VideoBuffers::DiscardFrames(0): AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA -- done
2007-01-20 00:17:36.729 VideoOutputXv: DiscardFrames() 3: AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA -- done()
2007-01-20 00:17:36.729 detectInterlace(Detect Scan, Interlaced Scan, 29.97, 480) ->Interlaced Scan
2007-01-20 00:17:36.731 AO: OutputAudioLoop: audio paused
2007-01-20 00:17:36.731 AO: 65536 bytes free on soundcard
2007-01-20 00:17:36.735 AO: 62156 bytes free on soundcard
2007-01-20 00:17:36.739 AO: 58800 bytes free on soundcard
2007-01-20 00:17:36.743 AO: 59564 bytes free on soundcard
2007-01-20 00:17:36.747 AO: 60332 bytes free on soundcard
2007-01-20 00:17:36.749 DVDNAV_HOP_CHANNEL happened.
2007-01-20 00:17:36.749 DVDNAV_CELL_CHANGE: pg_length == 675000, pgc_length == 720000, cell_start == 0, pg_start == 0, title == 5, part == 1 titleParts 2
2007-01-20 00:17:36.750 DVDNAV_SPU_CLUT_CHANGE happened.
2007-01-20 00:17:36.750 DVDNAV_SPU_STREAM_CHANGE: physical_wide==-1, physical_letterbox==-1, physical_pan_scan==-1, logical==3384986
2007-01-20 00:17:36.750 DVDNAV_AUDIO_STREAM_CHANGE: physical==-1, logical==-1
2007-01-20 00:17:36.751 AO: 61104 bytes free on soundcard
2007-01-20 00:17:36.754 AO: 61696 bytes free on soundcard

This output repeats every time the logo repeats.

Attachments (5)

mythoutput.log (42.8 KB) - added by luitjens@… 13 years ago.
remove_unnecesary_seek_cell_start.diff (448 bytes) - added by skamithi 13 years ago.
attempt2.diff (896 bytes) - added by skamithi 13 years ago.
prevent precise seeking when jumping to a cell start.. . just curious if it resolves the issue in this ticket.
debug_ticket_2952.diff (1.2 KB) - added by skamithi 13 years ago.
debug patch to help find out the problem.
frontend.log (91.6 KB) - added by anonymous 13 years ago.
Frontend log from startup, through auto-play of DVD, selection of main feature from menu, and three complete loops of the THX sting

Download all attachments as: .zip

Change History (20)

comment:1 Changed 13 years ago by skamithi

Owner: changed from Anduin Withers to skamithi

comment:2 Changed 13 years ago by skamithi

are you running the latest svn rev ? If not, then upgrade. If you are, then I need the entire mythfrontend -v playback output, from the time you hit, play dvd, to the time you kill mythfrontend cause its looping.

Changed 13 years ago by luitjens@…

Attachment: mythoutput.log added

comment:3 in reply to:  2 Changed 13 years ago by luitjens@…

Replying to skamithi:

are you running the latest svn rev ? If not, then upgrade. If you are, then I need the entire mythfrontend -v playback output, from the time you hit, play dvd, to the time you kill mythfrontend cause its looping.

I am running revision 12576 which was the latest revision yesterday afternoon. I have attached the log you have requested. In this run I let the DVD loop 3 times before quitting.

comment:4 Changed 13 years ago by luitjens@…

Here is the configure line I configured with:

./configure --tune=athlon-tbird --cpu=athlon-tbird --enable-proc-opt --enable-lirc --enable-xvmc --enable-xvmc-opengl

comment:5 Changed 13 years ago by skamithi

Status: newassigned

Changed 13 years ago by skamithi

comment:6 Changed 13 years ago by skamithi

please try the attached patch.

comment:7 Changed 13 years ago by luitjens@…

Attached patch did not fix the looping.

comment:8 Changed 13 years ago by skamithi

okay i'll borrow the illusionist in a few weeks and investigate the issue.

Changed 13 years ago by skamithi

Attachment: attempt2.diff added

prevent precise seeking when jumping to a cell start.. . just curious if it resolves the issue in this ticket.

comment:9 Changed 13 years ago by skamithi

(In [12606]) Refs #2952. remove unnecessary call to dvdringbuf::seekcellstart. ensure that precise seeking is disabled when issuing a seekcellstart.

comment:10 Changed 13 years ago by skamithi

(In [12616]) Refs #2952. typo in [12606]. should be an 'and' not an 'or'.

comment:11 Changed 13 years ago by maillists@…

I am also seeing this (constant repetition of the THX sting) when attempting to play the main feature of Pirates of the Caribbean - The curse of the Black Pearl (Region 2).

I'm happy to do any additional debug information gathering you might want.

Changed 13 years ago by skamithi

Attachment: debug_ticket_2952.diff added

debug patch to help find out the problem.

comment:12 Changed 13 years ago by skamithi

pls apply the debug patch.. and collect the -v playback output. thx.

comment:13 Changed 13 years ago by luitjens@…

I no longer have the DVD, it was a rental. Can the other user who has reported seeing this on the black perl please do this?

Thanks

Changed 13 years ago by anonymous

Attachment: frontend.log added

Frontend log from startup, through auto-play of DVD, selection of main feature from menu, and three complete loops of the THX sting

comment:14 Changed 13 years ago by skamithi

(In [12691]) Refs #2952: internal dvd player. remove workaround used in the past to ensure that the menu spu is produced when you jump into the menu. looks like after the ffmpeg sync fixed this and now this workaround is causing the looping.

comment:15 Changed 13 years ago by skamithi

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.