Opened 13 years ago

Closed 10 years ago

Last modified 10 years ago

#2960 closed defect (invalid)

Powering off or killing frontend server when watching LiveTV leaves backend recording.

Reported by: marc@… Owned by: cpinkham
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If you are watching Live TV and you use a shortcut key sequence to go to another plugin like MythMusic, the backend keeps recording LiveTV even though nobody is watching anymore. To clear this condition then requires restarting the MythBackend?.

Frontend and backend running SVN 12199.

Change History (9)

comment:1 Changed 13 years ago by marc@…

The problem actually occurs when the frontend is turned off during LiveTV (I have seperate frontend / backend computers). I have a lirc command to execute "poweroff" at the frontend, if you execute this during LiveTV playback the backend just keeps on recording LiveTV.

comment:2 Changed 13 years ago by cpinkham

Summary: Using shortcut key to leave LiveTV leaves backend recordingPowering off or killing frontend server when watching LiveTV leaves backend recording.

"Doctor, it hurts when I do this."

"Well, don't do that."

comment:3 Changed 13 years ago by cpinkham

Owner: changed from Isaac Richards to cpinkham

Moving this into my view as I've been looking into this because of something else I've been working on anyway.

comment:4 Changed 13 years ago by benguzzo@…

I have experienced the same issue. MythFrontend 0.20.0.svn20061001 (Mac OS X 10.4.8), MythBackend? 0.20_p11626 (Gentoo Linux x86). Frontend crashing (or force-quitting) during LiveTV leaves backend recording; only way to fix it is to restart the backend. Worse, backend doesn't switch out of LiveTV mode to record scheduled shows.

comment:5 Changed 13 years ago by Janne Grunau

Version: 0.20head

comment:6 Changed 11 years ago by Dibblah

Status: newassigned

comment:7 Changed 10 years ago by stuartm

Component: mythtvMythTV - Recording
Status: assignedinfoneeded

Can anyone reproduce this with current trunk? The original/follow-up reports are pretty old (0.20 etc)

comment:8 Changed 10 years ago by stuartm

Resolution: invalid
Status: infoneededclosed

30 days without response.

comment:9 Changed 10 years ago by Ronald Frazier <ron@…>

This has not been fixed in 0.22-fixes. I just tested. Schedule a record, put a frontend to LiveTV on the same tuner that is scheduled to be recorded on, then disconnect power from the livetv frontend. Backend stays in LiveTV and misses recording.

Note: See TracTickets for help on using tickets.