Opened 13 years ago

Closed 13 years ago

#3007 closed defect (worksforme)

Perl script mkiconmap.pl

Reported by: dhighley@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Using svnversion 12659 and xmltv-0.5.45 I get an empty iconmap.xml file when I run: [root@douglas ~]# perl mythtv/contrib/mkiconmap.pl Calling tv_grab_na_icons...

Postal Code: 98023

Lineup? 0: 4DTV ( USA ) 1: AFN Satellite ( USA ) 2: C-Band ( USA ) 3: Click!Network Tacoma Power - Cable ( Tacoma ) 4: Click!Network Tacoma Power - Digital ( Tacoma ) 5: Comcast - Cable ( Federal Way ) 6: Comcast - Cable ( Tacoma ) 7: Comcast - Digital ( Federal Way ) 8: Comcast - Digital ( Tacoma ) 9: DIRECTV ( USA ) 10: DIRECTV Seattle ( Seattle ) 11: DISH Network ( USA ) 12: DISH Seattle ( Seattle ) 13: Local Broadcast ( Antenna ) Select one: [0,1,2,3,4,5,6,7,8,9,10,11,12,13 (default=3)] 7 *WARNING* Can't find all channels link, hope we got them all!

not well-formed (invalid token) at line 167, column 1139, byte 12119 at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/XML/Parser.pm line 187 Generating iconmap.xml...

Change History (5)

comment:1 Changed 13 years ago by dhighley@…

After further testing I submitted a problem report with the xmltv project, http://svn.mythtv.org/trac/ticket/3007. They did more testing and have found that a change in, Perl module HTML::TreeBuilder? v 3.22, has broken things. So we should close this report.

comment:2 Changed 13 years ago by dhighley@…

Darn I put the wrong cross reference for the xmltv problem report above. It should have been: https://sourceforge.net/tracker/?func=detail&atid=424135&aid=1653788&group_id=39046

comment:3 Changed 13 years ago by xris

FYI, this script may soon be obselete. I'm looking for testers/volunteers for the new channel_icons.pl script in contrib.

comment:4 Changed 13 years ago by dhighley@…

I tried the new channel_icons.pl script with svn version 12977. I found all but 10 of the 121 channels. It then prompted but would not allow me to skip channels so it did not update the channel icons.

comment:5 Changed 13 years ago by xris

Resolution: worksforme
Status: newclosed

dhighley - the "skip" bug has since been fixed, and I've just removed mkiconmap.pl from the repository.

Note: See TracTickets for help on using tickets.