Opened 12 years ago

Closed 11 years ago

#3045 closed patch (wontfix)

Guessing avsync errors when changing channels on DVB-S

Reported by: support@… Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This is simiar to problem #1960, and I have checked that the code in WrapTimecode? is present in my build of MythTV.

I'm off 0.20-fixes r12172. The hardware is an M2NPV-VM board with NVidia 6150 graphics and an AM2-3600X2 processor. Currently got NVidia driver 9626 and I've also tried enabling UseEvents? in my X settings.

I didn't enable "Use Video as the Timebase" as this appears to speed up the audio slightly changing the pitch.

The error output from the frontend is as follows

2007-02-05 10:09:04.785 Video timing method: USleep with busy wait
[mpegts @ 0xb7223db8]Parser not found for Codec Id: 94211 !
2007-02-05 10:09:06.391 VideoOutputXv: XvMCTex: Init failed
2007-02-05 10:09:06.391 VideoOutputXv: XVideo Adaptor Name: 'NV17 Video Texture'
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  142
  Minor opcode:  14
  Resource id:  0x190
2007-02-05 10:09:06.804 AFD: Opened codec 0x82fdca0, id(MPEG2VIDEO) type(Video)
2007-02-05 10:09:06.837 AFD: Opened codec 0x9fae370, id(MP3) type(Audio)
2007-02-05 10:09:07.046 Opening OSS audio device '/dev/dsp'.
2007-02-05 10:09:07.051 NVP: Enabling Audio
[mpegts @ 0xb7223db8]Parser not found for Codec Id: 94211 !
Unable to launch application
2007-02-05 10:09:24.082 AFD: Opened codec 0x9778bd0, id(MPEG2VIDEO) type(Video)
2007-02-05 10:09:24.083 AFD: Opened codec 0x9780dc0, id(MP3) type(Audio)
2007-02-05 10:09:25.455 NVP: Prebuffer wait timed out 10 times.
Unable to launch application
2007-02-05 10:09:31.264 New DB connection, total: 3
2007-02-05 10:09:31.264 msg: On same multiplex...
2007-02-05 10:09:31.282 Connected to database 'mythconverg' at host: localhost
2007-02-05 10:09:31.772 NVP: prebuffering pause
[mpegts @ 0xb7223db8]Parser not found for Codec Id: 94211 !
2007-02-05 10:09:31.960 AFD: Opened codec 0x9778bd0, id(MPEG2VIDEO) type(Video)
2007-02-05 10:09:31.960 AFD: Opened codec 0x9780dc0, id(MP3) type(Audio)
2007-02-05 10:09:33.637 Guessing at new AV sync values
2007-02-05 10:09:52.344 TV: Attempting to change from WatchingLiveTV to None
Unable to launch application
2007-02-05 10:09:52.627 TV: Changing from WatchingLiveTV to None

Any ideas on how to troubleshoot this.

Attachments (1)

jerky_video.patch (10.9 KB) - added by support@… 12 years ago.
Fix for jerky video on channel changes due to WarpTimecode?

Download all attachments as: .zip

Change History (5)

comment:1 Changed 12 years ago by support@…

I appear to have a fix for this. The problem isn't present in the main SVN trunk, and I've managed to backport the required components. This appears to fix a series of problems.

  1. Reduces risk of NVP: Timed out waiting for free video buffers appearing
  2. Fixes audio/video stutter/jitter problem when quickly changing chanels - a particular problems with DVB channels on the same multiplex
  3. Removes "Guessing at new AV sync values" messages
  4. General audio sync of DVB appears to be a lot closer to the video.

The might be a slight video jump sometimes when changing channel, but overall playback is greatly improved. The enclosed patch incorporates a backport of the following components from trunk -

The patch is built against 0.20-fixes r13188

This has passed all of our internal testing so I'll sortly be releasing the patch to customers as it makes a huge difference for any DVB users.

Changed 12 years ago by support@…

Attachment: jerky_video.patch added

Fix for jerky video on channel changes due to WarpTimecode?

comment:2 Changed 11 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:3 Changed 11 years ago by danielk

Milestone: unknown0.21
Status: assignedinfoneeded
Type: defectpatch

Is this still a problem with head? If so can you update the patch to svn head?

comment:4 Changed 11 years ago by danielk

Resolution: wontfix
Status: infoneededclosed

Sorry, I missed the first part of the first comment on the ticket. This is already fixed in head and is just a backport of those fixes to 0.20..

Note: See TracTickets for help on using tickets.