Opened 13 years ago

Closed 13 years ago

#3055 closed defect (duplicate)

Switching channels to different tuner/input doesn't honor channel requested, uses startchan

Reported by: Mark.Buechler@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Somewhere between 12431 and 12730 a change went in which breaks tuning to a different channel on a different tuner and cardinput. In other words, while in LiveTV cardid 1 I switch to cardid 2, which has a defaultinput of 1, input 2 channel 110 myth instead tunes to cardinput.startchan for input 1. I believe this change was related to quicktune, specifically in tv_rec.cpp GetDTVChannel(), but I'm not entirely certain.

Frontend, backend and sql log portions attached.

Attachments (1)

logs.txt (5.5 KB) - added by Mark.Buechler@… 13 years ago.
Logs

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by Mark.Buechler@…

Attachment: logs.txt added

Logs

comment:1 Changed 13 years ago by anonymous

I belive this is the same as #2643 . This has in been error for many months and exists in 0.20-fixes branch.

comment:2 Changed 13 years ago by Mark.Buechler@…

I mistyped the function I believe to have changed causing this. I believe it's TVRec::TuningFrequency?().

comment:3 Changed 13 years ago by Janne Grunau

Resolution: duplicate
Status: newclosed

duplicate of #2643

Note: See TracTickets for help on using tickets.