Opened 13 years ago

Closed 13 years ago

#3058 closed defect (invalid)

losing 3-4 minutes at end of programs

Reported by: eric.bosch@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: nfs record playback
Cc: Ticket locked: no

Description

I'm running latest svn (12739), with frontend/backend running on primary machine (with one PVR350 tuner), with a secondary backend (with two PVR150 tuners) saving recordings via nfs to primary backend server. I have noticed that all programs recorded over this seem to end about 2-3 minutes prematurely, even though it shows length of program to be 29:57, or 59:57 minutes. When I view the program and get to the point it's about 2-3 minutes from the end of the program, the playback simply stops. I'm not certain if recordings from the tuner on the primary box are having this issue at this point, but it seems that it is related to nfs, in that the remainder of the Ringbuffer doesn't get committed to the destination file properly. I have the NFS rbuffer set at 8192, and have the wbuffer set to 256. The other result of this behavior is while watching livetv on the primary server from one of the tuners on the secondary backend, I get momentary pauses about every 1-2 seconds, unless I pause the program for a few moments, and then play with a timestretch setting at 0.9, preventing the player from reaching the end of the file being written to. I have tried various wbuffer settings up to 8192, and it simply seems to require a longer pause before playback. There is nothing notable in the log files.

Change History (3)

comment:1 Changed 13 years ago by anonymous

Version: 0.20head

comment:2 Changed 13 years ago by eric.bosch@…

I would like to have this ticket closed as I found the cause of this issue on my system. At some point Dynamic CPU speed throttling became functional, and it turns out my PC was running at 400MHz-800MHz when not under a load. If the load was increased, the CPU speed would be increased. It appears that this may be an issue that could be addressed in the Mythtv code. If I was watching live-tv, cpu load would be around 30% at 400MHz, apparently not enough to trigger the Speed governor. If a recording was going on in the background, load levels were extremely low (2-3%) in backend, but would have some apparent data loss. After bumping the cpu governor to "performance" rather than "on-demand", cpu speed remains at 3.2GHz, and there are no apparent problems of data loss, etc, and the CPU load while watching LiveTV is around 10%.

comment:3 Changed 13 years ago by Stuart Auchterlonie

Resolution: invalid
Status: newclosed

Closing by request

Note: See TracTickets for help on using tickets.