Opened 14 years ago

Closed 13 years ago

#3114 closed defect (invalid)

mythbackend crashes with "Unknown file transfer socket: 22"

Reported by: sean@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: high Keywords: mythbackend
Cc: Ticket locked: no

Description

During LiveTV or watching recordings, the client machine will freeze, and then timeout with a message saying it cannot reach the server. The logs show that mythbackend crashing with the message "Unknown file transfer socket: 22". Sometimes the socket number is 15.

I have always had this problem, starting about 6 months ago with the server running on Gentoo, so I switched to Ubuntu to see if it was related to dependencies. Problem still occurred. Tried both Gentoo and Ubuntu on the client, and now Xebian on an xbox all with the same results. Just replaced the server with an entirely new box (3ghz) but same results.

Used to happen maybe once a day, but now happens within an hour of playback.

Commercial detection and transcoding is turned off on the backend.

Ubuntu build appears to be 0.20.20060828-3

Logs for the most recent crash end with:

2007-02-20 18:02:03.947 MSqlQuery: SELECT lastrun FROM housekeeping WHERE tag = 'JobQueueCleanup?' ; 2007-02-20 18:02:03.957 MSqlQuery: SELECT lastrun FROM housekeeping WHERE tag = 'InUseProgramsCleanup?' ; 2007-02-20 18:02:03.959 MSqlQuery: SELECT lastrun FROM housekeeping WHERE tag = 'JobQueueRecover?-gandalf' ; 2007-02-20 18:02:09.086 JobQueue?: Currently set at 1 job(s) max and to run new jobs from 00:00 to 23:59 2007-02-20 18:02:09.097 MSqlQuery: SELECT j.id, j.chanid, j.starttime, j.inserttime, j.type, j.cmds, j.flags, j.status, j.statustime, j.hostname, j.args, j.comment, r.endtime FRO M jobqueue j, recorded r WHERE j.chanid = r.chanid AND j.starttime = r.starttime ORDER BY j.inserttime, j.chanid, j.id; 2007-02-20 18:02:09.098 JobQueue?: GetJobsInQueue?: findJobs search bitmask 4, found 3 total jobs 2007-02-20 18:02:09.098 JobQueue?: GetJobsInQueue?: Found 'Flag Commercials' Job for 1049 @ 20070219063000 in Queued state. 2007-02-20 18:02:09.099 JobQueue?: GetJobsInQueue?: Found 'Flag Commercials' Job for 1049 @ 20070219200003 in Queued state. 2007-02-20 18:02:09.100 JobQueue?: GetJobsInQueue?: Found 'Flag Commercials' Job for 1049 @ 20070220063000 in Queued state. 2007-02-20 18:02:09.101 JobQueue?: Currently Running 0 jobs. 2007-02-20 18:02:09.101 JobQueue?: Skipping 'Flag Commercials' job for chanid 1049 @ 20070219063000, not allowed to run on this backend. 2007-02-20 18:02:09.102 JobQueue?: Skipping 'Flag Commercials' job for chanid 1049 @ 20070219200003, not allowed to run on this backend. 2007-02-20 18:02:09.102 JobQueue?: Skipping 'Flag Commercials' job for chanid 1049 @ 20070220063000, not allowed to run on this backend. 2007-02-20 18:02:34.796 MSqlQuery: SELECT chanid, starttime, lastupdatetime, recusage, hostname FROM inuseprograms; 2007-02-20 18:02:34.805 AutoExpire?: Adding Programs to 'Do Not Expire' List 2007-02-20 18:02:34.806 1007 @ Tue Feb 20 10:00:00 2007 in use by player on legolas 2007-02-20 18:02:34.807 AutoExpire?: ExpireLiveTV(10000) 2007-02-20 18:02:34.809 MSqlQuery: SELECT recorded.chanid, starttime, endtime, title, subtitle, description, hostname, channum, name,

callsign, seriesid, programid, recorded.recpriority, progstart, progend, filesize, recgroup FROM recorded LEFT JOIN cha

nnel ON recorded.chanid = channel.chanid WHERE recgroup = 'LiveTV' AND endtime < DATE_ADD(starttime, INTERVAL '2' MINUTE) AND endtime <= DATE_ADD(NOW(), INTERVAL '-1' MINUTE) AN D hostname = 'gandalf' AND deletepending = 0 ORDER BY autoexpire DESC, starttime ASC 2007-02-20 18:02:34.810 AutoExpire?: SendDeleteMessages?. Nothing to expire. 2007-02-20 18:02:53.194 MythSocket?(819b0f0:17): socket is readable 2007-02-20 18:02:53.204 MythSocket?(819b0f0:17): socket closed 2007-02-20 18:02:53.205 MythSocket?(819b0f0:17): state change Connected -> Idle 2007-02-20 18:02:53.206 MythSocket?(819b0f0:-1): cb->connectionClosed() 2007-02-20 18:02:53.206 MythSocket?(8198bb8:18): socket is readable 2007-02-20 18:02:53.207 MythSocket?(8198bb8:18): socket closed 2007-02-20 18:02:53.208 MythSocket?(8198bb8:18): state change Connected -> Idle 2007-02-20 18:02:53.208 MythSocket?(8198bb8:-1): cb->connectionClosed() 2007-02-20 18:02:53.209 MythSocket?(81d8150:22): socket is readable 2007-02-20 18:02:53.209 MythSocket?(81d8150:22): socket closed 2007-02-20 18:02:53.210 MythSocket?(81d8150:22): state change Connected -> Idle 2007-02-20 18:02:53.210 MythSocket?(81d8150:-1): cb->connectionClosed() 2007-02-20 18:02:53.211 MythSocket?(81d8150:-1): DownRef?: 0 2007-02-20 18:02:53.211 MythSocket?(81d8150:-1): DownRef?: -1 2007-02-20 18:02:53.212 MythSocket?(81d8150:-1): delete socket 2007-02-20 18:03:01.749 MythSocket?(81f4f10:21): socket is readable 2007-02-20 18:03:01.750 MythSocket?(81f4f10:21): cb->readyRead() 2007-02-20 18:03:01.751 MythSocket?(81f4f10:21): UpRef?: 2 2007-02-20 18:03:01.751 read <- 21 50 QUERY_FILETRANSFER 22[]:[]REQUEST_BLOCK[]:[]131072 2007-02-20 18:03:01.764 Unknown file transfer socket: 22 2007-02-20 18:03:01.764 MythSocket?: readyread thread exit 2007-02-20 18:04:17.454 Using runtime prefix = /usr

Can provide more complete logs if needed.

Attachments (1)

logs.txt (4.1 KB) - added by sean@… 14 years ago.
the logs

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by sean@…

Attachment: logs.txt added

the logs

comment:1 Changed 14 years ago by heydan@…

I'm having the same problem:

2007-04-23 15:33:16.381 Unknown file transfer socket: 0

comment:2 Changed 14 years ago by heydan@…

This link suggests the problem might have to do with generating preview thumbnails:

http://www.opensubscriber.com/message/mythtv-dev@mythtv.org/759103.html

comment:3 Changed 13 years ago by stuartm

Resolution: invalid
Status: newclosed

Please provide a backtrace according to the instructions here: http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

I don't know the cause of the unknown socket, but the backtrace should at least fix the crash and possibly help figure out the issue.

Note: See TracTickets for help on using tickets.