Opened 12 years ago

Closed 11 years ago

#3185 closed defect (invalid)

Mythweb mythvideo dir error

Reported by: anonymous Owned by: Rob Smith
Priority: trivial Milestone: unknown
Component: mythweb Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Just installed svn 12991 when i try to go into mythvideo in mythweb it gives the following error:

Error Could not create a symlink to /mnt/store/movies, the local MythVideo? directory for this hostname (mythhd). Please create a symlink to your MythVideo? directory at data/video in order to use the video portions of MythWeb.

Thats all fine except that it has already created a valid symlink to that directory and it is valid. if i delete the symlink it will re-create it but still give the error.

Change History (11)

comment:1 Changed 12 years ago by xris

Owner: changed from xris to Rob Smith

comment:2 Changed 12 years ago by Rob Smith

(In [13000]) Re #3117, adds in a save funciton to the video object, cleans up some code, re #3185, fixes the duplicate error message.

comment:3 Changed 12 years ago by anonymous

Almoast there. in 13003 i get the same error but in: "MythVideo? directory at data/video_covers in order to use the video artwork"

If i delete both symlinks video@ and video_covers@ from data and reload it creates them and let's me in to mythvideo, if i the go back adn try to access mythvideo again i get the error.

comment:4 Changed 12 years ago by Rob Smith

Status: newassigned

Can you give me the output of a ls -l on the data directory (I'd like to see what the symlink is and all that jazz). I'm really wondering what is going on, as all it does is check if it's a directory or a symlink.

You don't have something really strange in your setup do you?

comment:5 Changed 12 years ago by anonymous

-rw-rw-r-- 1 nobody root 180 2007-03-10 12:32 .htaccess drwxrwxr-x 7 nobody root 392 2007-03-12 23:14 .svn/ drwxr-xr-x 2 nobody nobody 6432 2007-03-12 22:24 cache/ lrwxrwxrwx 1 nobody nobody 17 2007-03-10 12:36 music -> /mnt/store/music drwxr-xr-x 2 nobody nobody 368 2007-03-10 12:35 tv_icons/ lrwxrwxrwx 1 nobody nobody 17 2007-03-11 13:08 video -> /mnt/store/movies/ lrwxrwxrwx 1 nobody nobody 23 2007-03-11 13:08 video_covers -> /home/myth/.mythtv/MythVideo/

comment:6 Changed 12 years ago by anonymous

Just tried to change the Artwork dir to /mnt/store/MythVideo and changed the path in the database, all works fine after that.

comment:7 Changed 12 years ago by Rob Smith

Resolution: worksforme
Status: assignedclosed

Closing as reported as working fine.

comment:8 Changed 11 years ago by yourimatthys@…

Resolution: worksforme
Status: closednew

Dear,

I'm experiencing the same error. The symlinks are wrongly created and as a workaround i had to remove them and recreate them as directory's so i could mount them with "mount -o bind". With this dirty hack, the video directory is fine and video's can be played on both the localhost and the remote hosts. Video covers are still unavailable though.

Before using this dirty hack i've verified all permissions/ownership on both the directory's and the symlinks. Both were fine imho.

gentoo linux / Mythweb 0.21_p16809

Regards, Youri

comment:9 Changed 11 years ago by Rob Smith

Are you running apache chrooted by chance?

comment:10 Changed 11 years ago by Rob Smith

Status: newinfoneeded_new

comment:11 Changed 11 years ago by stuartm

Resolution: invalid
Status: infoneeded_newclosed

Requested information not provided.

Note: See TracTickets for help on using tickets.