Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#3230 closed defect (wontfix)

Unable to import certain newer DVDs

Reported by: anonymous Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: mythvideo Version: 0.20
Severity: medium Keywords: mythdvd import fail
Cc: Ticket locked: no

Description

When trying to import newer DVD releases, such as Stranger Than Fiction there are a few problems:

(1) When showing the number of tracks available for import mythdvd reports 99 tracks available, which I doubt is correct. Several of the tracks have the (seemingly) correct length of approximately 2 hours.

(2) When trying to rip at any other quality than "ISO," the progress screen briefly comes up, and then quickly returns to the "hit 0 for new import" screen

(3) When trying to rip at "ISO" quality, the rip continues for a couple of minutes and writes between 700MB-800MB to the disk and then suddenly crashes back to the "hit 0 for new import" screen.

I am imported several other DVDs successfully and the hard disk is not close to being full. After looking into /var/log/messages on my system (Gentoo), I saw these errors:

Mar 18 17:43:47 localhost hdc: media error (bad sector): error=0x30 { LastFailed
Sense=0x03 }
Mar 18 17:43:47 localhost ide: failed opcode was: unknown
Mar 18 17:43:47 localhost ATAPI device hdc:
Mar 18 17:43:47 localhost Error: Medium error -- (Sense key=0x03)
Mar 18 17:43:47 localhost (reserved error code) -- (asc=0x11, ascq=0x05)
Mar 18 17:43:47 localhost The failed "Read 10" packet command was:
Mar 18 17:43:47 localhost "28 00 00 06 30 40 00 00 40 00 00 00 00 00 00 00 "
Mar 18 17:43:47 localhost end_request: I/O error, dev hdc, sector 1622272
Mar 18 17:43:47 localhost printk: 86 messages suppressed.
Mar 18 17:43:47 localhost Buffer I/O error on device hdc, logical block 202784
Mar 18 17:43:47 localhost Buffer I/O error on device hdc, logical block 202785
Mar 18 17:43:47 localhost Buffer I/O error on device hdc, logical block 202786
Mar 18 17:43:47 localhost Buffer I/O error on device hdc, logical block 202787
Mar 18 17:43:47 localhost Buffer I/O error on device hdc, logical block 202788
Mar 18 17:43:47 localhost Buffer I/O error on device hdc, logical block 202789
Mar 18 17:43:47 localhost Buffer I/O error on device hdc, logical block 202790
Mar 18 17:43:47 localhost Buffer I/O error on device hdc, logical block 202791
Mar 18 17:43:47 localhost Buffer I/O error on device hdc, logical block 202792
Mar 18 17:43:47 localhost Buffer I/O error on device hdc, logical block 202793
Mar 18 17:47:08 localhost hdc: media error (bad sector): status=0x51 { DriveRead
y SeekComplete Error }
Mar 18 17:47:08 localhost hdc: media error (bad sector): error=0x30 { LastFailed
Sense=0x03 }

The DVD has no visible scratches on it. After doing some Googling, I found other DVD rippers having similar problems. Please see: http://forum.doom9.org/archive/index.php/t-123124.html

In summary, this seems to be some sort of purposeful-bad-block scheme, in order to prevent users from creating copies of our own DVDs! I have seen this problem on another DVD I own, but I can't be sure it is the same thing...


System Information


Gentoo Linux Kernel: linux-2.6.18-gentoo-r3


MythTv? packages:

[ebuild R ] media-tv/mythtv-0.20_p12963 USE="alsa dvb dvd ieee1394 ivtv lirc mmx opengl perl vorbis xvmc (-altivec) -autostart -backendonly -crciprec -dbox2 -debug -dts -freebox -frontendonly -hdhomerun -jack -joystick -lcd" VIDEO_CARDS="nvidia -i810 -via" 0 kB

[ebuild R ] media-plugins/mythdvd-0.20_p11329 USE="transcode vcd -debug -mm x" 0 kB


output of hdparm -I /dev/hdc:

ATAPI CD-ROM, with removable media

Model Number: LITE-ON DVDRW SHW-160P6S Serial Number: Firmware Revision: PS01

Standards:

Used: ATAPI for CD-ROMs, SFF-8020i, r2.5 Supported: CD-ROM ATAPI-2

Configuration:

DRQ response: 50us. Packet size: 12 bytes

Capabilities:

LBA, IORDY(cannot be disabled) DMA: *sdma0 *sdma1 *sdma2 sdma3 sdma4 sdma7 mdma0 mdma1 mdma2 udma0 udma

1 udma2 udma3 *udma4 (?)

Cycle time: min=120ns recommended=120ns

PIO: pio0 pio1 pio2 pio3 pio4

Cycle time: no flow control=240ns IORDY flow control=120ns

Commands/features:

Enabled Supported:

  • PACKET command feature set
  • DEVICE_RESET command
  • Mandatory FLUSH_CACHE

HW reset results:

CBLID- below Vih Device num = 0

Change History (7)

comment:1 Changed 13 years ago by Anduin Withers

Component: mythtvmythvideo
Owner: changed from Isaac Richards to Anduin Withers

comment:2 Changed 13 years ago by Anduin Withers

The best you will ever see in Myth's DVD import is better error reporting or an option it ignore errors. Your DVD is not defective, it is failing as it was intended to.

And no, this was not a good reason to open a ticket.

comment:3 Changed 13 years ago by anonymous

Thank you for you comments. I am not sure why this is not a good ticket? Can I provide you with more useful information? Perhaps there is an underlying component (outside of mythtv) to which I can report this issue?

Thanks again for your time.

comment:4 Changed 13 years ago by fracmak

I've been noticing this on certain newer dvds as well. Seems a lot of rippers have this problem, often times the first couple sectors of the main movie track will have bad sectors, but hitting the "play" dvd menu will skip those first couple sectors and so the dvd will play just fine when you watch it. I looked at the code a bunch and this most of the dvd reading he handled by libdvd, which is failing on these sectors, I don't know if it's worth while for us to try and guess on whether or not these failures are bad sectors or a scratched disk and try skipping them, if it would create bad rips, or whether this is something more for libdvd to do? Or maybe trying to parse the dvd navigation some and detect when the start of the movie isn't the start of the track?

Anyways, just some thoughts

comment:5 Changed 13 years ago by anonymous

I like your idea for an option that would "ignore bad sectors."

Also, would it be possible to rip the DVD in such a way that it would rip in real time just like you were watching it (maybe even while you are watching it). This would be kind of a "what you see is what you get" approach and might be a good last-resort for DVD ripping.

comment:6 Changed 13 years ago by Anduin Withers

Resolution: wontfix
Status: newclosed

Discussions, especially of the "me too" or "I second that" belong on the mail list, not in closed tickets.

comment:7 Changed 13 years ago by anonymous

It is a waste of tickets because the ticket numbers themselves are held as 12 bit numbers and thus once we reach ticket number 4095 there can be no more bugs. We must therefore use our tickets wisely.

Note: See TracTickets for help on using tickets.