Opened 12 years ago

Closed 12 years ago

#3236 closed defect (worksforme)

Mythweb SVN13075 Mythvideo thumbnails missing and link to videos incorrect.

Reported by: anonymous Owned by: Rob Smith
Priority: trivial Milestone: 0.21
Component: mythweb Version: head
Severity: low Keywords: mythweb mythvideo
Cc: Ticket locked: no

Description (last modified by Rob Smith)

For the past month mythweb in trunk has been broken in the mythvideo section. I have missing thumbnails and the links to the video files are broken/incorrect.

I run mythweb on a non-mythtv host (ie no back or frontend). My mythvideos are stored on the same host as mythweb in /storage/videos and is nfs shared to the front and backend as /var/lib/mythtv/videos. I have symlinked /var/lib/mythtv/videos on this host to /storage/videos.

Mythweb made some symlinks in its data dir...

lrwxrwxrwx 1 www-data www-data   15 2007-03-19 18:10 video -> /storage/videos
lrwxrwxrwx 1 www-data www-data   25 2007-03-19 18:10 video_covers -> /storage/videos/.videoart

which is correct.

Now when i set Mythvideo Dir via mythweb and the artwork dir to /storage/videos and /storage/videos/.videoart, going to mythvideos in mythweb produces these urls... http://10.0.1.251/mythweb/data/video//var/lib/mythtv/videos/xxxxx.avi

When i try to set the Mythvideo Dir via mythweb to /var/lib/mythtv/videos i get a java popup which tells me that dir doesnt exist and wont let me set it.

When i try to set the Mythvideo Dir via mythweb to blank and remove the rows from settings table I get the same sort of urls... http://10.0.1.251/mythweb/data/video//var/lib/mythtv/videos/xxxxx.avi

i have played with it all sorts of ways and have not been able to get the tumbnails or links working.

Change History (7)

comment:1 Changed 12 years ago by xris

Owner: changed from xris to Rob Smith

comment:2 Changed 12 years ago by Rob Smith

Status: newassigned

can you please post the output of

SELECT videometadata.*
  FROM videometadata
 LIMIT 1

comment:3 Changed 12 years ago by Rob Smith

Description: modified (diff)

comment:4 Changed 12 years ago by anonymous

OK I went past the java popup for setting my video dir and set it manualy to /var/lib/mythtv/videos and /var/lib/mythtv/videos/.videoart and now the links to the files are correct, but the art is still not displaying. The difference appears to be video dir must be set to /var/lib/mythtv/videos which is a symlink and mythweb would not let me set it. Setting it to the actual path /storage/videos produced the funny urls.

Cover art is still not correct, right clicking on the images and chooesing properties shows no url. Clicking on edit or imdb results in error on page in IE like there is a broken javascript.

below is the output from what you asked....

| 291 | Borat: Cultural Learnings of America for Make Benefit Glorious Nation of Kazakhstan | Larry Charles | Kazakh TV talking head Borat is dispatched to the United States to report on the greatest country in the world. With a documentary crew in tow, Borat becomes more inter ested in locating and marrying Pamela Anderson. | Rated R for pervasive strong crude and sexual content including graphic nudity, and langua ge. | 0443453 | 2006 | 7.8 | 84 | 1 | /var/lib/mythtv/videos/Borat.avi | /var/lib/mythtv/videos/.videoart/0443453.jpg | -1 | 1 | | 0 |

comment:5 Changed 12 years ago by Janne Grunau

Version: 0.20head

comment:6 Changed 12 years ago by anonymous

Anyone still having issues in the current SVN?

comment:7 Changed 12 years ago by Rob Smith

Resolution: worksforme
Status: assignedclosed

No updates for awhile, can't reproduce, reopen if still is an issue in current svn.

Note: See TracTickets for help on using tickets.