Opened 13 years ago

Closed 12 years ago

#3259 closed defect (invalid)

Menus in mythfrontend are blank screens if more than one user session active in Kubuntu

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: 0.20
Severity: medium Keywords: button, icon, navigation screens, mythfrontend
Cc: friedel@… Ticket locked: no

Description

Overview

If there is more than a single user session logged into Kubuntu then all of the navigational menus in mythfrontend display as blank (black) screens.

Curiously you can still use the up and down arrows to move between options. You can't see anything, but the options can be selected using the Enter key. If you get lucky you can almost use the application.

The problem occurs for all of the themes that I managed to change to: Myth Center, Retro, and Myth Center Wide.

All of the "normal" screens display and work fine. Only the navigational menus are blank.

With only a single user logged into Kubuntu, mythfrontend works as expected everywhere.

Reason it's a problem

I am using MythTV on our Linux desktop machine which always has someone other than mythtv logged in. I'm also using the XBox Media Center (XBMC) MythTV frontend for viewing and it's often faster to use the native Linux frontend on our desktop to specify recordings. Having to log out all users to do that is getting pretty frustrating.

Environment

Kubuntu Edgy Eft with an updated Linux kernel (2.6.20.3) so I can use the latest IVTV drivers for my PVR-150 card.

The problem also occurred with the generic kernel that Edgy Eft ships with and the 0.7 IVTV drivers (not that they should affect anything).

Standard distro of MythTV 0.20 with K/ubuntu.

Change History (5)

comment:1 Changed 13 years ago by mythtv@…

I'm sure I filled in my email address when I submitted the ticket. Hopefully this update records it.

comment:2 Changed 13 years ago by friedel@…

Cc: friedel@… added
Keywords: button icon navigation screens mythfrontend added

Hi!

I see a very similar problem with mythtv 0.20 (just compiling 0.20-fixes to see if it's still there).

All the navigational screens in mythfrontend have partially missing icons. In the first screen, (blue theme) the upper line is completely blank (blue background) but the second line is normal, in the setup screen, I see two blank circles, so I can guess which of them is for changing the theme.

The retro theme has no icons at all.

I tried moving my whole ~/.mythtv directory away, after going through the frontend setup again (mysql password) the bug was still there.

I can't confirm that it's related to more than one user being logged in. mythfrontend crashed a couple of times before that effect occured, also it seems unrelated to the kernel version (didn't see it with both 2.6.19.2 and 2.6.20-rc4-rt0 at first), however it appeared after those crashes/hangs and after I tried configuring sound output to use JACK via mythweb.

Using debian unstable, nvidia driver 9746, xorg 7.1.1, libqt3-mt 3.3.7-3. Please tell me what information I can provide to help you find the problem.

Kind regards Friedel

comment:3 Changed 13 years ago by friedel@…

Update:

I've just discovered that this problem disappears completely when I switch to the Qt renderer. I didn't notice this before because I forgot to actually quit the frontend manually and start it again, because I mistook the disappearing and re-appearing window for an automatic restart.

Note that switching to the Qt renderer also helps with a different problem I've seen: Whenever I start an openGL app while the frontend is running at the same time (for example /usr/lib/xscreensaver/lament -fps &), it slowed to a crawl when mythfrontend was running. That doesn't happen with the Qt renderer.

Since I've seen similar problems with other openGL apps with certain versions of the nvidia driver, I'm sticking with the Qt renderer for now.

HTH Kind regards Friedel

comment:4 Changed 13 years ago by mythtv@…

I've changed mythfrontend's configuration to use the QT engine from OpenGL and it appears to be working fine with multiple user sessions now. Fantastic. Thanks.

comment:5 Changed 12 years ago by stuartm

Resolution: invalid
Status: newclosed

Appears to be a limitation of opengl/the nvidia driver.

Note: See TracTickets for help on using tickets.