Opened 12 years ago

Closed 12 years ago

#3264 closed defect (worksforme)

issue compiling mythgallery

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythgallery Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

-using svn version: At revision 13132. -using compile directives:

mini-myth mythplugins # ./configure --prefix=/usr/local/mythtv

Configuration settings:

MythArchive? plugin will be built MythBrowser? plugin will be built MythControls? plugin will be built MythFlix? plugin will be built MythDVD plugin will be built MythGallery plugin will be built MythGame? plugin will be built MythMusic plugin will be built MythNews? plugin will be built MythPhone? plugin will be built MythVideo? plugin will be built MythWeather? plugin will be built DVD creation support will be included in MythArchive? Native Archive support will be included in MythArchive? OpenGL support will be included in MythGallery EXIF support will be included in MythGallery OpenGL support will be included in MythMusic FFTW v.3 support will be included in MythMusic SDL support will be included in MythMusic AAC support will not be included in MythMusic FESTIVAL support will not be included in MythPhone?


-execution of make generates following results:

mini-myth mythplugins # make cd mytharchive && make -f Makefile make[1]: Entering directory `/opt/mythplugins/mytharchive' cd mytharchive && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mytharchive/mytharchive' qmake -o Makefile mytharchive.pro make[2]: Leaving directory `/opt/mythplugins/mytharchive/mytharchive' make[2]: Entering directory `/opt/mythplugins/mytharchive/mytharchive' g++ -c -pipe -march=k8 -I/usr/kde/3.5/include/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -Wno-non-virtual-dtor -Wall -W -O3 -fomit-frame-pointer -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC -D_GNU_SOURCE -DPREFIX=\"/usr/local/mythtv-0.20-stable\" -DMMX -Di386 -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I. -I/usr/local/mythtv-0.20-stable/include -I/usr/kde/3.5/include -I/usr/local/mythtv-0.20-stable/include -I/usr/include -I/usr/include -I/usr/local/mythtv-0.20-stable/include/mythtv -I/usr/qt/3/include -o main.o main.cpp /usr/qt/3/include/qsqldatabase.h:63: warning: 'class QSqlDriverCreatorBase' has virtual functions but non-virtual destructor rm -f libmytharchive.so g++ -shared -o libmytharchive.so main.o archivesettings.o logviewer.o fileselector.o recordingselector.o videoselector.o dbcheck.o archiveutil.o mythburnwizard.o editmetadata.o exportnativewizard.o importnativewizard.o moc_logviewer.o moc_fileselector.o moc_recordingselector.o moc_videoselector.o moc_mythburnwizard.o moc_editmetadata.o moc_exportnativewizard.o moc_importnativewizard.o -L/usr/kde/3.5/lib -L/usr/qt/3/lib -L/usr/local/mythtv-0.20-stable/lib -lqt-mt -lpthread make[2]: Leaving directory `/opt/mythplugins/mytharchive/mytharchive' cd mytharchivehelper && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mytharchive/mytharchivehelper' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mytharchive/mytharchivehelper' cd i18n && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mytharchive/i18n' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mytharchive/i18n' make[1]: Leaving directory `/opt/mythplugins/mytharchive' cd mythbrowser && make -f Makefile make[1]: Entering directory `/opt/mythplugins/mythbrowser' cd mythbrowser && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mythbrowser/mythbrowser' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mythbrowser/mythbrowser' cd mythbookmarkmanager && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mythbrowser/mythbookmarkmanager' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mythbrowser/mythbookmarkmanager' cd i18n && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mythbrowser/i18n' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mythbrowser/i18n' make[1]: Leaving directory `/opt/mythplugins/mythbrowser' cd mythcontrols && make -f Makefile make[1]: Entering directory `/opt/mythplugins/mythcontrols' cd mythcontrols && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mythcontrols/mythcontrols' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mythcontrols/mythcontrols' cd i18n && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mythcontrols/i18n' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mythcontrols/i18n' make[1]: Leaving directory `/opt/mythplugins/mythcontrols' cd mythflix && make -f Makefile make[1]: Entering directory `/opt/mythplugins/mythflix' cd mythflix && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mythflix/mythflix' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mythflix/mythflix' cd i18n && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mythflix/i18n' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mythflix/i18n' make[1]: Leaving directory `/opt/mythplugins/mythflix' cd mythdvd && make -f Makefile make[1]: Entering directory `/opt/mythplugins/mythdvd' cd mythdvd && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mythdvd/mythdvd' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mythdvd/mythdvd' cd mtd && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mythdvd/mtd' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mythdvd/mtd' cd i18n && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mythdvd/i18n' make[2]: Nothing to be done for `first'. make[2]: Leaving directory `/opt/mythplugins/mythdvd/i18n' make[1]: Leaving directory `/opt/mythplugins/mythdvd' cd mythgallery && make -f Makefile make[1]: Entering directory `/opt/mythplugins/mythgallery' cd mythgallery && make -f Makefile make[2]: Entering directory `/opt/mythplugins/mythgallery/mythgallery' qmake -o Makefile mythgallery.pro make[2]: Leaving directory `/opt/mythplugins/mythgallery/mythgallery' make[2]: Entering directory `/opt/mythplugins/mythgallery/mythgallery' g++ -c -pipe -march=k8 -I/usr/kde/3.5/include/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -Wno-non-virtual-dtor -Wall -W -O3 -fomit-frame-pointer -Wall -Wno-switch -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC -D_GNU_SOURCE -DPREFIX=\"/usr/local/mythtv-0.20-stable\" -DMMX -Di386 -D_FILE_OFFSET_BITS=64 -DUSING_OPENGL -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_PLUGIN -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/qt/3/mkspecs/linux-g++ -I. -I/usr/local/mythtv-0.20-stable/include -I/usr/kde/3.5/include -I/usr/local/mythtv-0.20-stable/include -I/usr/include -I/usr/include -I/usr/qt/3/include -I/usr/include -o gallerysettings.o gallerysettings.cpp /usr/qt/3/include/qsqldatabase.h:63: warning: 'class QSqlDriverCreatorBase' has virtual functions but non-virtual destructor gallerysettings.cpp: In constructor 'GalleryConfigurationGroup::GalleryConfigurationGroup?()': gallerysettings.cpp:181: error: reference to 'setLabel' is ambiguous /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:119: error: candidates are: void Configurable::setLabel(QString) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:119: error: void Configurable::setLabel(QString) gallerysettings.cpp:181: error: reference to 'setLabel' is ambiguous /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:119: error: candidates are: void Configurable::setLabel(QString) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:119: error: void Configurable::setLabel(QString) gallerysettings.cpp:182: error: reference to 'setUseLabel' is ambiguous /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:845: error: candidates are: void ConfigurationGroup::setUseLabel(bool) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:845: error: void ConfigurationGroup::setUseLabel(bool) gallerysettings.cpp:182: error: reference to 'setUseLabel' is ambiguous /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:845: error: candidates are: void ConfigurationGroup::setUseLabel(bool) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:845: error: void ConfigurationGroup::setUseLabel(bool) gallerysettings.cpp:186: error: reference to 'addChild' is ambiguous /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: candidates are: void ConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:988: error: virtual void TriggeredConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: void ConfigurationGroup::addChild(Configurable*) gallerysettings.cpp:186: error: reference to 'addChild' is ambiguous /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: candidates are: void ConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:988: error: virtual void TriggeredConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: void ConfigurationGroup::addChild(Configurable*) gallerysettings.cpp:205: error: reference to 'addChild' is ambiguous /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: candidates are: void ConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:988: error: virtual void TriggeredConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: void ConfigurationGroup::addChild(Configurable*) gallerysettings.cpp:205: error: reference to 'addChild' is ambiguous /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: candidates are: void ConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:988: error: virtual void TriggeredConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: void ConfigurationGroup::addChild(Configurable*) gallerysettings.cpp:206: error: reference to 'addChild' is ambiguous /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: candidates are: void ConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:988: error: virtual void TriggeredConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: void ConfigurationGroup::addChild(Configurable*) gallerysettings.cpp:206: error: reference to 'addChild' is ambiguous /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: candidates are: void ConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:988: error: virtual void TriggeredConfigurationGroup::addChild(Configurable*) /usr/local/mythtv-0.20-stable/include/mythtv/settings.h:834: error: void ConfigurationGroup::addChild(Configurable*) gallerysettings.cpp: In constructor 'GallerySettings::GallerySettings?()': gallerysettings.cpp:224: error: 'Configurable' is an ambiguous base of 'GalleryConfigurationGroup?' make[2]: * [gallerysettings.o] Error 1 make[2]: Leaving directory `/opt/mythplugins/mythgallery/mythgallery' make[1]: * [sub-mythgallery] Error 2 make[1]: Leaving directory `/opt/mythplugins/mythgallery' make: * [sub-mythgallery] Error 2 mini-myth mythplugins #

Change History (1)

comment:1 Changed 12 years ago by stuartm

Milestone: unknown0.21
Resolution: worksforme
Status: newclosed

I can't reproduce. Try a make distclean, check that you don't have two different versions of mythtv libs installed etc.

Note: See TracTickets for help on using tickets.