Opened 12 years ago

Closed 12 years ago

#3340 closed defect (fixed)

Recorded Programmes list (LiveTV) does not update count in group chooser droplist

Reported by: Nick Morrott <knowledgejunkie@…> Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: mythweb Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Deleting LiveTV recordings from the Recorded Programmes page does not fully refresh the page, but updates the section of the page from where the recording was displayed to remove it.

When deleting 6 LiveTV programs from a total of 7, the group chooser droplist maintained that there were still 7 LiveTV recordings present, even when the 6 has been deleted. It was not until I forced a full refresh of the page that the count was corrected down to 1.

Attachments (1)

3340_mythweb_update_recgroup_count_v1.diff (3.2 KB) - added by Nick Morrott <knowledgejunkie@…> 12 years ago.
Patch to fix recording group count update on Recorded Programmes page

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by xris

Resolution: worksforme
Status: newclosed

I can't reproduce this. Please reopen if you can get me some javascript errors.

comment:2 Changed 12 years ago by Nick Morrott <knowledgejunkie@…>

Resolution: worksforme
Status: closedreopened

After looking through my JS error logs and testing in Firefox and IE with the same results, I then hit SVN. Looking at lines 159-160 of mythweb/modules/tv/tmpl/default/recorded.php it appears this functionality is potentially broken and untested:

159 TODO: test changing the groups dropdown on the fly. 160 I can't test it because I haven't set up any recording groups, and probably never will

I note from my testing that both the 'Show Recordings' droplist and the disk usage message at the foot of the page are successfully updated on each delete, and it is only the group droplist that is not updated on-the-fly.

I have tested this behaviour with the Default group and the LiveTV group, with the same behaviour for both. I don't have any extra recording groups defined apart from these two standard groups.

Any way I can help test this for you and get it fixed?

Cheers, Nick

comment:3 Changed 12 years ago by Nick Morrott <knowledgejunkie@…>

After having another look at the code and some initial guidance by kormoc on IRC, I have fixed the update problem with the attached patch. I'm guessing there was a fair bit of copy'n'paste to get some rough code for this feature, which meant a few incorrect variables were being referenced in the recording group count update :)

Cheers, Nick

Changed 12 years ago by Nick Morrott <knowledgejunkie@…>

Patch to fix recording group count update on Recorded Programmes page

comment:4 Changed 12 years ago by Rob Smith

Owner: changed from xris to Rob Smith
Status: reopenednew

comment:5 Changed 12 years ago by Rob Smith

Resolution: fixed
Status: newclosed

(In [13480]) Fixes #3340, this commits the patch from knowledgejunkie to fix the group chooser droplist on deletes on the recorded tv page

Note: See TracTickets for help on using tickets.