Opened 14 years ago

Closed 14 years ago

#337 closed defect (duplicate)

Channel browsing does not work with channel browser (dvb)

Reported by: lukas.kasprowicz@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: high Keywords:
Cc: Ticket locked: no

Description

Hi,

first, this is not the same problem like 330.

When trying to use channel browser, to zap to another channel, in 7252, OSD shows "No Lock". After filling startchan with channel where to zap, it works without any problems. zapping back does only work by filling in new channel to startchan and restarting mythbackend.

I tried to zap, restart frontend, like in 330, but mythbackend was not availible anymore.

In backend log i found a frequency, where it zaps to and this frequency shows one more digit then the old frequency.

First initial tune:

2005-09-15 14:26:17.375 DVB#0 Device Name: 'Conexant CX24110 DVB-S'
2005-09-15 14:26:17.383 DVB#0 Opening DVB channel
2005-09-15 14:26:18.093 DVB#0 Trying to tune to channel 12020.
2005-09-15 14:26:18.113 New DB connection, total: 3
2005-09-15 14:26:18.126 DVB#0 Frequency: 12187500 Symbol Rate: 27500000 Pol: H/L Inv: Auto
2005-09-15 14:26:19.512 DVB#0 Old Params: freq(0) type(QPSK)
2005-09-15 14:26:19.527 DVB#0 New Params: freq(12187500) type(QPSK)
2005-09-15 14:26:19.618 dvbchannel.cpp:wait_for_backend: Status:
2005-09-15 14:26:19.662 DVB#0 DVBChannel::Tune: Frequency tuning successful.
2005-09-15 14:26:19.691 DVB#0 Tuned to frequency for channel 12020.
2005-09-15 14:26:19.743 DVB#0 Opening DVB channel

Channel change:

2005-09-15 14:30:47.629 DVB#0 Trying to tune to channel 898.
2005-09-15 14:30:47.631 DVB#0 Frequency: 12480000 Symbol Rate: 27500000 Pol: V/R Inv: Auto
2005-09-15 14:30:47.785 DVB#0 Old Params: freq(1587500) type(QPSK)
2005-09-15 14:30:47.786 DVB#0 New Params: freq(12480000) type(QPSK)
2005-09-15 14:30:47.786 dvbchannel.cpp:wait_for_backend: Status:
2005-09-15 14:30:47.786 DVB#0 DVBChannel::Tune: Frequency tuning successful.
2005-09-15 14:30:47.786 DVB#0 Tuned to frequency for channel 898.
2005-09-15 14:30:47.787 DVB#0 Opening DVB channel
2005-09-15 14:30:48.795 SM(0)::AddFlags: Seen() Match() Wait(Sig,SNR,BER,UB,)
2005-09-15 14:30:48.795 DVBSM(0)::constructor(): initial flags 0x7400000
2005-09-15 14:30:48.796 DTVSM(0)::SetProgramNumber(898):
2005-09-15 14:30:48.796 SM(0)::RemoveFlags: Seen(PMT,) Match(PMT,) Wait()
2005-09-15 14:30:48.796 SM(0)::AddFlags: Seen() Match() Wait(PMT,)
2005-09-15 14:30:48.797 SM(0)::AddFlags: Seen() Match() Wait(PAT,PMT,)
2005-09-15 14:30:48.798 SM(0)::Start: begin
2005-09-15 14:30:48.802 DTVSM(0)::GetStatusList: WaitForPMT seen(0) matching(0)
2005-09-15 14:30:48.804 SM(0)::Start: end
2005-09-15 14:30:54.425 DVBSM(0)::UpdateValues: Signal Locked
2005-09-15 14:30:54.426 DVBSM(0)::UpdateValues: Waiting for table monitor to start
2005-09-15 14:30:54.426 DVBSM(0)::UpdateValues: Table monitor started
2005-09-15 14:30:54.434 DVBSM(0)::RunTableMonitor(): begin (# of pids 2)
2005-09-15 14:30:54.434 DVBSM(0)::AddPIDFilter(0x0):
2005-09-15 14:30:54.435 DVBSM(0)::AddPIDFilter(0x1ffb):

After this Screen appears black no reaction to keystrokes, but OSD showed 'No Lock'

This appeared while/after stopping backend 4 times:

2005-09-15 14:33:45.703 SM(0)::AddFlags: Seen(PAT,) Match() Wait()
2005-09-15 14:33:45.703 Program #898 not found in PAT!
Program Association Table
 PSIP prefix(0x0) tableID(0x0) length(129) extension(0x5)
      version(17) current(1) section(0) last_section(0)
         tsid: 5
 programCount: 30
  program number 0 has PID 0x  10   data  0x0 0x0 0x224 0x16
  program number 60 has PID 0x  62   data  0x0 0x60 0x224 0x98
  program number 61 has PID 0x  63   data  0x0 0x61 0x224 0x99
  program number 62 has PID 0x  65   data  0x0 0x62 0x224 0x101
  program number 63 has PID 0x  66   data  0x0 0x63 0x224 0x102
  program number 64 has PID 0x  80   data  0x0 0x64 0x224 0x128
  program number 65 has PID 0x  81   data  0x0 0x65 0x224 0x129
  program number 66 has PID 0x  82   data  0x0 0x66 0x224 0x130
  program number 67 has PID 0x  83   data  0x0 0x67 0x224 0x131
  program number 100 has PID 0x  70   data  0x0 0x100 0x224 0x112
  program number 101 has PID 0x  71   data  0x0 0x101 0x224 0x113
  program number 171 has PID 0x  68   data  0x0 0x171 0x224 0x104
  program number 172 has PID 0x  84   data  0x0 0x172 0x224 0x132
  program number 173 has PID 0x  85   data  0x0 0x173 0x224 0x133
  program number 174 has PID 0x  86   data  0x0 0x174 0x224 0x134
  program number 400 has PID 0x  75   data  0x1 0x144 0x224 0x117
  program number 401 has PID 0x  76   data  0x1 0x145 0x224 0x118
  program number 402 has PID 0x  77   data  0x1 0x146 0x224 0x119
  program number 403 has PID 0x  78   data  0x1 0x147 0x224 0x120
  program number 404 has PID 0x  79   data  0x1 0x148 0x224 0x121
  program number 405 has PID 0x  7a   data  0x1 0x149 0x224 0x122
  program number 406 has PID 0x  7b   data  0x1 0x150 0x224 0x123
  program number 407 has PID 0x  7c   data  0x1 0x151 0x224 0x124
  program number 408 has PID 0x  7d   data  0x1 0x152 0x224 0x125
  program number 409 has PID 0x  7e   data  0x1 0x153 0x224 0x126
  program number 659 has PID 0x  6c   data  0x2 0x147 0x224 0x108
  program number 662 has PID 0x  69   data  0x2 0x150 0x224 0x105
  program number 663 has PID 0x  64   data  0x2 0x151 0x224 0x100
  program number 3959 has PID 0x  67   data  0x15 0x119 0x224 0x103
  program number 3961 has PID 0x  61   data  0x15 0x121 0x224 0x97

After changing startchan and restarting backend it tuned to channel 898:

2005-09-15 14:40:20.925 DVB#0 Device Name: 'Conexant CX24110 DVB-S'
2005-09-15 14:40:20.926 DVB#0 Opening DVB channel
2005-09-15 14:40:21.822 DVB#0 Trying to tune to channel 898.
2005-09-15 14:40:21.824 New DB connection, total: 3
2005-09-15 14:40:21.826 DVB#0 Frequency: 12480000 Symbol Rate: 27500000 Pol: V/R Inv: Auto
2005-09-15 14:40:22.729 DVB#0 Old Params: freq(0) type(QPSK)
2005-09-15 14:40:22.729 DVB#0 New Params: freq(12480000) type(QPSK)
2005-09-15 14:40:22.730 dvbchannel.cpp:wait_for_backend: Status:
2005-09-15 14:40:22.731 DVB#0 DVBChannel::Tune: Frequency tuning successful.
2005-09-15 14:40:22.731 DVB#0 Tuned to frequency for channel 898.
2005-09-15 14:40:22.731 DVB#0 Opening DVB channel
2005-09-15 14:40:22.764 SM(0)::AddFlags: Seen() Match() Wait(Sig,SNR,BER,UB,)
2005-09-15 14:40:22.764 DVBSM(0)::constructor(): initial flags 0x7400000
2005-09-15 14:40:22.764 DTVSM(0)::SetProgramNumber(898):
2005-09-15 14:40:22.765 SM(0)::RemoveFlags: Seen(PMT,) Match(PMT,) Wait()
2005-09-15 14:40:22.765 SM(0)::AddFlags: Seen() Match() Wait(PMT,)
2005-09-15 14:40:22.766 SM(0)::AddFlags: Seen() Match() Wait(PAT,PMT,)
2005-09-15 14:40:22.766 SM(0)::Start: begin
2005-09-15 14:40:22.772 SM(0)::Start: end
2005-09-15 14:40:22.773 DTVSM(0)::GetStatusList: WaitForPMT seen(0) matching(0)
2005-09-15 14:40:22.834 DVBSM(0)::UpdateValues: Signal Locked
2005-09-15 14:40:22.835 DVBSM(0)::UpdateValues: Waiting for table monitor to start
2005-09-15 14:40:22.835 DVBSM(0)::UpdateValues: Table monitor started
2005-09-15 14:40:22.842 DVBSM(0)::RunTableMonitor(): begin (# of pids 2)
2005-09-15 14:40:22.842 DVBSM(0)::AddPIDFilter(0x0):
2005-09-15 14:40:22.843 DVBSM(0)::AddPIDFilter(0x1ffb):
2005-09-15 14:40:22.900 SM(0)::AddFlags: Seen(PAT,) Match() Wait()
2005-09-15 14:40:22.901 SM(0)::AddFlags: Seen() Match(PAT,) Wait()
2005-09-15 14:40:22.901 DVBSM(0)::AddPIDFilter(0x64):
2005-09-15 14:40:22.908 SM(0)::AddFlags: Seen(PMT,) Match() Wait()
2005-09-15 14:40:22.909 SM(0)::AddFlags: Seen() Match(PMT,) Wait()
2005-09-15 14:40:22.916 DTVSM(0)::GetStatusList: WaitForPMT seen(1) matching(1)
2005-09-15 14:40:22.918 DVBSM(0)::Stop: begin
2005-09-15 14:40:22.918 SM(0)::Stop: begin
2005-09-15 14:40:22.944 SM(0)::Stop: end
2005-09-15 14:40:22.948 DVBSM(0)::RunTableMonitor(): shutdown
2005-09-15 14:40:22.949 DVBSM(0)::RemovePIDFilter(0x0):
2005-09-15 14:40:22.949 DVBSM(0)::RemovePIDFilter(0x64):
2005-09-15 14:40:22.949 DVBSM(0)::RemovePIDFilter(0x1ffb):
2005-09-15 14:40:22.949 DVBSM(0)::RunTableMonitor(): end
2005-09-15 14:40:22.950 DVBSM(0)::Stop: end
2005-09-15 14:40:22.950 DVBSM(0)::Stop: begin
2005-09-15 14:40:22.950 SM(0)::Stop: begin
2005-09-15 14:40:22.951 SM(0)::Stop: end
2005-09-15 14:40:22.951 DVBSM(0)::Stop: end
2005-09-15 14:40:22.951 SM(0)::Stop: begin
2005-09-15 14:40:22.951 SM(0)::Stop: end
2005-09-15 14:40:22.978 New DB scheduler connection
2005-09-15 14:40:22.988 mythbackend version: 0.19.20050712-1 www.mythtv.org
2005-09-15 14:40:22.989 Enabled verbose msgs :important channel
2005-09-15 14:40:22.992 AutoExpire: Found 1 recorders w/max rate of 138 MiB/min
2005-09-15 14:40:22.993 AutoExpire: space: 2.0 GB w/freq: 10 min

Zapping back did not work, too:

005-09-15 15:39:18.661 DVB#0 Trying to tune to channel 12003.
2005-09-15 15:39:18.664 DVB#0 Frequency: 12187500 Symbol Rate: 27500000 Pol: H/L Inv: Auto
2005-09-15 15:39:18.826 DVB#0 Old Params: freq(1880000) type(QPSK)
2005-09-15 15:39:18.827 DVB#0 New Params: freq(12187500) type(QPSK)
2005-09-15 15:39:18.827 dvbchannel.cpp:wait_for_backend: Status:
2005-09-15 15:39:18.827 DVB#0 DVBChannel::Tune: Frequency tuning successful.
2005-09-15 15:39:18.827 DVB#0 Tuned to frequency for channel 12003.
2005-09-15 15:39:18.828 DVB#0 Opening DVB channel
2005-09-15 15:39:19.845 SM(0)::AddFlags: Seen() Match() Wait(Sig,SNR,BER,UB,)
2005-09-15 15:39:19.845 DVBSM(0)::constructor(): initial flags 0x7400000
2005-09-15 15:39:19.846 DTVSM(0)::SetProgramNumber(12003):
2005-09-15 15:39:19.846 SM(0)::RemoveFlags: Seen(PMT,) Match(PMT,) Wait()
2005-09-15 15:39:19.846 SM(0)::AddFlags: Seen() Match() Wait(PMT,)
2005-09-15 15:39:19.847 SM(0)::AddFlags: Seen() Match() Wait(PAT,PMT,)
2005-09-15 15:39:19.848 SM(0)::Start: begin
2005-09-15 15:39:19.852 DTVSM(0)::GetStatusList: WaitForPMT seen(0) matching(0)
2005-09-15 15:39:19.853 SM(0)::Start: end
2005-09-15 15:39:25.552 DVBSM(0)::UpdateValues: Signal Locked
2005-09-15 15:39:25.553 DVBSM(0)::UpdateValues: Waiting for table monitor to start
2005-09-15 15:39:25.553 DVBSM(0)::UpdateValues: Table monitor started
2005-09-15 15:39:25.560 DVBSM(0)::RunTableMonitor(): begin (# of pids 2)
2005-09-15 15:39:25.561 DVBSM(0)::AddPIDFilter(0x0):
2005-09-15 15:39:25.563 DVBSM(0)::AddPIDFilter(0x1ffb):

This is reproducible everytime i try to change channel.

Lukas

Change History (2)

comment:1 Changed 14 years ago by Adam Egger

Daniel, this one is exactly the "Magical-Adam-Egger-bug" we were trying to fix on my system two or three weeks ago. I'm now mostly able to switch to another channels without any problems. I only got this black screen with No-Lock once after I'd changed my startchan to a different channel. I had to kill my FE then and the strange thing was that the tuner died after the the FE was killed.

comment:2 Changed 14 years ago by danielk

Resolution: duplicate
Status: newclosed

This appears to be a duplicate of #326.

Note: See TracTickets for help on using tickets.