Opened 13 years ago

Closed 12 years ago

#3400 closed defect (duplicate)

Compilation fails on machines with VIA C7 processor

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This is really a gcc bug, but since the C7 seems to be a popular processor it might be worth it adding a workaround in the configure script.

ccache gcc -c -pipe -march=c3 -w -fomit-frame-pointer -Wall -Wno-switch -O2 -fomit-frame-pointer -D_REENTRANT -DPIC -fPIC -DMMX -Di386 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DPREFIX=\"/usr\" -DLIBDIR=\"/usr/lib\" -DHAVE_AV_CONFIG_H -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -DQT_TABLET_SUPPORT -I/usr/share/qt3/mkspecs/default -I. -I.. -I../.. -I../libavutil -I/usr/include/qt3 -o motion_est.o motion_est.c motion_est_template.c: In function â: motion_est_template.c:413: error: can't find a register in class â while reloading â make: * [motion_est.o] Error 1

The code builds successfully when using ./configure --tune=i686.

Change History (2)

comment:1 Changed 12 years ago by Rich D

This looks to be the same bug as 3694 and if so then the fix for that should have fixed this as well.

comment:2 Changed 12 years ago by Janne Grunau

Resolution: duplicate
Status: newclosed

duplicate of #3694

Note: See TracTickets for help on using tickets.