Opened 14 years ago

Closed 14 years ago

#360 closed patch (wontfix)

verbose arg parsing in mythbacked

Reported by: asmythtv@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version:
Severity: low Keywords:
Cc: Ticket locked: no

Description

If you specify any of all, none, or quiet, it overides the others contrary to what the help says. And siparser is missing from the help.

Fix the help in line 416 to:

"                               Accepts one of: all, none, quiet  OR" << endl <<
"                               any combination (separated by comma) of:" << endl <<
"                               record,playback,channel,osd,file,schedule," << endl <<
"                               network,commflag,audio,libav,jobqueue,siparser" << endl <<

This isn't 100% correct, as you can do quiet,audio - to give you just important, and audio messages (i.e. without general messages). But it's a little hard to get that (that those 3 must be first, if used) across in a short help text.

Change History (1)

comment:1 Changed 14 years ago by danielk

Resolution: wontfix
Status: newclosed

A hidden feature is not a bug :)

There are many hidden features in MythTV...

Note: See TracTickets for help on using tickets.