Opened 12 years ago

Closed 12 years ago

#3730 closed defect (fixed)

mythshutdown ignores early recording start times

Reported by: anonymous Owned by: stuartm
Priority: minor Milestone: 0.21
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: Ticket locked: no

Description

If you schedule to record a program with a record start time that > 15 minutes earlier then the EPG start time, mythbackend will not record the program. This problem happens when the box is shutdown and it wakes up automatically to record the program. The file scheduler.cpp will check that current time is less that 15 minutes away than the recording start, otherwise will shutdown the box, because it is idle.

The problem is that curtime is compared against startts (EPG start time) and not recstarts (actual recrding start time). My suggestion is to change the line 1223 from:

((curtime.secsTo((*startIter)->startts) - prerollseconds)

to

((curtime.secsTo((*startIter)->recstartts) - prerollseconds)

and the line 1420 from:

if (curtime.secsTo((*startIter)->startts) -

to:

if (curtime.secsTo((*startIter)->recstartts) -

Change History (3)

comment:1 Changed 12 years ago by stuartm

Milestone: unknown0.21
Owner: changed from Isaac Richards to stuartm
Status: newassigned
Summary: mythbackend ignores early record startsmythshutdown ignores early recording start times

comment:2 Changed 12 years ago by stuartm

Status: assignedstarted

comment:3 Changed 12 years ago by stuartm

Resolution: fixed
Status: startedclosed

(In [15247]) Use the recording starttime, including per schedule offsets instead of the programme starttime when determing if we can shutdown the backend.

Closes #3730

Note: See TracTickets for help on using tickets.