Opened 12 years ago

Closed 11 years ago

#3844 closed defect (fixed)

MythWeb fails to show Rerun correctly

Reported by: otto at kolsi dot fi Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: mythweb Version: head
Severity: low Keywords: Rerun, previouslyshown
Cc: Ticket locked: no

Description

I have program data which has previouslyshown -field true for some programs. There are only valid values in DB:

mysql> select distinct previouslyshown from program;
+-----------------+
| previouslyshown |
+-----------------+
|               0 | 
|               1 | 
+-----------------+

Now sometimes some programs have double Rerun info in program listings:

href="/mythweb/tv/detail/1005/1187456400">
Jää henkiin</a> (<i>Rerun</i>)<br>(<i>Rerun</i>)
</td>

Then another problem is that depending on where in the page certain program is shown (e.g. first in the left or last in the right), it might show Rerun or not. And this is for a program that doesn't have previouslyshown flag true:

mysql> select chanid, title, previouslyshown from program where title like 'Kuusi p%';                                         
+--------+------------------------------------+-----------------+
| chanid | title                              | previouslyshown |
+--------+------------------------------------+-----------------+
|   1004 | Kuusi päivää, seitsemän yötä |               0 | 
|   3004 | Kuusi päivää, seitsemän yötä |               0 | 
+--------+------------------------------------+-----------------+

Here are 2 examples from the same program:

<img src="/mythweb/skins/default/img/right_sm.png" class="right_arrow"
border="0">Kuusi päivää, seitsemän yötä</a> (<i>Rerun</i>)</td>
<img src="/mythweb/skins/default/img/left_sm.png" class="left_arrow" 
border="0">Kuusi päivää, seitsemän yötä</a></td>

Attachments (1)

mythweb-rerun.patch (573 bytes) - added by otto at kolsi dot fi 11 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 12 years ago by Joe Ripley <vitaminjoe@…>

Not sure how this can happen.

http://svn.mythtv.org/trac/browser/trunk/mythplugins/mythweb/modules/tv/tmpl/default/list_cell_program.php#L64

This code can only display the '(Repeat)' (translated to 'Rerun') text once, as far as I can tell. I can't reproduce this problem.

-- Joe Ripley vitaminjoe@…

comment:2 Changed 12 years ago by Rob Smith

Owner: changed from xris to Rob Smith
Status: newassigned

Changed 11 years ago by otto at kolsi dot fi

Attachment: mythweb-rerun.patch added

comment:3 Changed 11 years ago by otto at kolsi dot fi

I've attached a patch that fixes this. Error occurs for movies that are reruns but do not have any additional info present (e.g. rating) because $parens variable is not emptied when it should.

comment:4 Changed 11 years ago by Rob Smith

Resolution: fixed
Status: acceptedclosed

(In [15494]) Fixes #3844, nice catch Mr. Otto

Note: See TracTickets for help on using tickets.