Opened 12 years ago

Closed 12 years ago

#3848 closed defect (fixed)

SQL error

Reported by: anonymous Owned by: xris
Priority: major Milestone: unknown
Component: mythweb Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When clicking on a channel name from inside the program detail window, I receive a Fatal Error saying that 'endtime' cannot be null. Full backtrace attached.

Attachments (1)

bug.txt (5.3 KB) - added by redchops@… 12 years ago.
Backtrace

Download all attachments as: .zip

Change History (9)

Changed 12 years ago by redchops@…

Attachment: bug.txt added

Backtrace

comment:1 in reply to:  description Changed 12 years ago by anonymous

Replying to anonymous:

When clicking on a channel name from inside the program detail window, I receive a Fatal Error saying that 'endtime' cannot be null. Full backtrace attached.

Component should be mythweb, my mistake

comment:2 Changed 12 years ago by paulh

Component: mythtvmythweb
Owner: changed from Isaac Richards to xris

comment:3 Changed 12 years ago by Joe Ripley <vitaminjoe@…>

This is most likely an error in the SQL database, not mythweb. Do:

select * from program where endtime is null

To see what program has the NULL endtime. Not sure how something like this would occur. How does the frontend deal with this program (as opposed to mythweb)?

-- Joe Ripley vitaminjoe@…

comment:4 Changed 12 years ago by redchops@…

It returns an empty set. As for the frontend, there are absolutely no problems.

comment:5 Changed 12 years ago by Joe Ripley <vitaminjoe@…>

Does this problem still exist for you? I can't reproduce it.

-- Joe Ripley vitaminjoe@…

comment:6 Changed 12 years ago by redchops@…

Yeah, still having it, although with the discontinuation of the free zap2it service, I'm not sure how much longer I'll be using the mythweb anyway

comment:7 Changed 12 years ago by xris

fyi, this seems to have happened because for some reason the user was requesting a time in the distant past (likely from corrupt EIT data). I'll put in a simple workaround for this to prevent the error in the future.

comment:8 Changed 12 years ago by xris

Resolution: fixed
Status: newclosed

(In [14631]) Workaround for corrupt program data to prevent database errors when program times are before the unix epoch started. closes #3848

Note: See TracTickets for help on using tickets.