Opened 12 years ago

Closed 11 years ago

#3928 closed defect (worksforme)

internal dvd player: enhance subtitle selection and fix dvd audio/subtitle track list names

Reported by: skamithi Owned by: skamithi
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Mythtv to date does not have a mechanism to properly map dvd subtitle track numbers to stream ids.

thanks to pekka I have a DVD that highlights this issue.

attaching patch shortly that resolves this issue. Patch also fixes language names show in the Subtitle/Audio? track list. also made minor modification to the dvd audio selection code (#3260)

Attachments (1)

1.diff (23.1 KB) - added by skamithi 12 years ago.
patch against latest rev

Download all attachments as: .zip

Change History (13)

Changed 12 years ago by skamithi

Attachment: 1.diff added

patch against latest rev

comment:1 Changed 12 years ago by skamithi

(In [14409]) Refs #3928. internal dvd player. enhance subtitle selection process and fix audio/subtitle track language names.

comment:2 Changed 12 years ago by skamithi

(In [14420]) Refs #3928. remove some changes i used for debugging.

comment:3 Changed 12 years ago by skamithi

Resolution: fixed
Status: newclosed

comment:4 Changed 12 years ago by maxchowhk@…

Resolution: fixed
Status: closedreopened

Sorry sir,

It seems that the fix still not fix my problem.

I can send the ISO file over to you, but you do need to provide me a ftp, because it is about 8G in size.

Thanks

Max

comment:5 Changed 12 years ago by skamithi

Resolution: fixed
Status: reopenedclosed

requested more info from person who reopened ticket. if the issue is valid, i'll reopen this ticket.

comment:6 Changed 12 years ago by maxchowhk@…

Please provide a FTP so I can upload the ISO image for you to inspection.

The DVD subtitle is still selecting wrongly.

Thanks

Max

comment:7 Changed 12 years ago by maxchowhk@…

Resolution: fixed
Status: closedreopened

Please provide a FTP so I can upload the ISO image for you to inspection.

The DVD subtitle is still selecting wrongly.

Thanks

Max

comment:8 Changed 12 years ago by skamithi

Milestone: 0.210.22

comment:9 Changed 12 years ago by skamithi

Milestone: 0.22unknown

comment:10 Changed 11 years ago by Dibblah

Status: newassigned

comment:11 Changed 11 years ago by anonymous

can you re-produce the problem from somewhere else?

comment:12 Changed 11 years ago by skamithi

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.