Opened 12 years ago

Closed 12 years ago

#3945 closed defect (invalid)

Re: [mythtv] Can't watch tv with Mythtv on freebox (RTSP)

Reported by: Benoit LORAND <benoit.lorand@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: rtsp freebox mythtv
Cc: Ticket locked: no

Description

Problem is occurring every time i want to watch tv. I'm oblige to restart mythbackend as many times as it would don't work. Since it will worked, i can watch some channels and it will block again.

Notice when mythtv doesn't work i can't see any log message in my mythbackend.log (playback,record)

Benoît LORAND a écrit :

Benoît LORAND a écrit :

hi,

Since many weeks, i can't watch tv with my freebox (RTSP). I tried

to rescan channel but nothing to do. I have an linux firewall between my freebox and my mythtv with rtsp kernel patch from http://mike.it-loops.com/rtsp. Is there anyone having same problem (with or not firewall).

Also i have same configuration when it worked.

Sorry, mythtv isn't faulty. My firewall was an 2.6.22.2 kernel and i found (http://mike.it-loops.com/) rtsp's patch doesn't work properly for this one.

Really sorry

Since i have say that's the rtsp patch's is faulty, i'm trying to resolve this with Michael Guntsche who develop rtsp patch's for linux. In fact the patch isn't problem's cause because i have vlc to continue to work when mythtv's fail. Can you tell me what log can help us to solve this and if i have to open ticket. (in attachment my mails with Michael Guntsche)

-- Benoît LORAND

http://www.blorand.org benoit.lorand@… Fax : 09 58 35 85 84

Sujet: Re: RTSP Mythtv patches De: Benoît LORAND <benoit.lorand@…> Date: Sat, 08 Sep 2007 15:25:41 +0200 Pour :: Michael Guntsche

Michael Guntsche a écrit :

On Sep 8, 2007, at 11:30, Benoît LORAND wrote:

Michael Guntsche a écrit :

Good morning,

Is it possible that you send me the patches via E-Mail. The comment system adds a whole bunch of markup and I want to compare this patch to mine.

Kind regards, Michael

good morning too,

thanks to see what's wrong in 2.6.22 and 2.6.23

Hello Benoit,

I had a look at the patches you send me and my current ones. Giving it a quick look there are no changes apart from API-changes. To completely understand your problem. Your are watching a stream and then your are switching to another stream which is not played then (streams are not played simulatinously). Is it possible for you to compile both modules with DEBUG enabled and send me the output. I tried it here and I am able to watch more than one stream at the same time. To enable debug output change the #if 0 for DEBUGP in both files. After rmmod/insmod the information should be logged to syslog.

Kind regards, Michael

Hello Michael,

In fact, after many test with debug activated. I know now that's my mythtv who have problem. I have try using playlist (see mail attechment) with vlc and its work properly. I'm oblige to reinitialize some times my mythbackend (program who record channel for time shifting) to have it working since vlc work anyway.

This day i'm sure it's not rtsp's patch who is faulty. I would try to see this problem with mythtv support.

Thanks a lot for your works, i'm sorry you lost your time.

Change History (3)

comment:1 Changed 12 years ago by Benoît LORAND <benoit.lorand@…>

some news:

up to date in the trunk (14520), having made research since, I realized after having declared a second tuner rtsp, that when I puts an imbricated tuner, I can change chains without problem in the other. If I does not do it, always the same problem the chains aren't "tuned" (verouillé in french) except that of departure (not all the time).

comment:2 Changed 12 years ago by Benoît LORAND <benoit.lorand@…>

New statement: (SVN 14675)

When I look at the chain by default some time (around 5 minutes), I have no problem to change the channel.

comment:3 Changed 12 years ago by danielk

Priority: blockerminor
Resolution: invalid
Severity: highmedium
Status: newclosed

I don't understand the problem description. It would be best if you could give the steps needed to reproduce this on a generic system not connected to any particular ISP.

Also this definitely isn't a blocker. IPTV support in MythTV is still experimental and problems with it should not block a release.

Note: See TracTickets for help on using tickets.