Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3977 closed defect (fixed)

"create storage group" selector in mythtv-setup sets "create..." as SG title

Reported by: xris Owned by: cpinkham
Priority: major Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: storage groups
Cc: Ticket locked: no

Description

as of r14496

Can't seem to create more than one alternate SG. When I click on "create new..." it creates a new one, but the title of the group is "create new...".

Also noticed that you can still hit "d" on the "add a new directory" link in the storage group editor, and it asks if I want to delete the "add..." directory.

Change History (3)

comment:1 Changed 12 years ago by anonymous

I can confirm this issue as of 14496 svn version.

comment:2 Changed 12 years ago by cpinkham

Resolution: fixed
Status: newclosed

(In [14531]) Modify the Storage Groups editor code to use non-empty values for its "create" buttons. The default actions of the SelectSetting? class changed in [14405] which broke this.

Fixes #3977.

comment:3 Changed 12 years ago by cpinkham

(In [14532]) Modify the Playback Groups editor code to use non-empty values for its "create" button. The default actions of the SelectSetting? class changed in [14405] which broke this.

References #3977 since it's the same issue/fix.

Note: See TracTickets for help on using tickets.