Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4089 closed defect (invalid)

Internal player skip forward takes about 10 secs to skip 5 seconds of video

Reported by: tafypz Owned by: Anduin Withers
Priority: major Milestone: 0.21
Component: mythvideo Version: head
Severity: medium Keywords: Internal player Mythvideo
Cc: Ticket locked: no

Description

Hi,

I recorded a HD program through mythtv, in the recording section of mythtv the file plays just fine with the internal player. Now if I copy this file to the mythvideo plugin folder (same disk) and use the Internal player skipping takes more time than the actual video playback. Using Mplayer instead works just fine. Ie a 5 sec skip takes about 10 secs. I use a remote frontend, recordings and Videos are made available through NFS.

The frontend log shows this when the skipping problem happens: RingBuf?(/mnt/media/mythtv/1002_20070412224349.mpg): Waited 1.0 seconds for data to become available... RingBuf?(/mnt/media/mythtv/1002_20070412224349.mpg): Waited 2.0 seconds for data to become available... RingBuf?(/mnt/media/mythtv/1002_20070412224349.mpg): Waited 1.0 seconds for data to become available... RingBuf?(/mnt/media/mythtv/1002_20070412224349.mpg): Waited 2.0 seconds for data to become available... RingBuf?(/mnt/media/mythtv/1002_20070412224349.mpg): Waited 2.0 seconds for data to become available...

I am using the svn 14696

Change History (5)

comment:1 Changed 12 years ago by Anduin Withers

Priority: minormajor

comment:2 Changed 12 years ago by Nigel

Resolution: invalid
Status: newclosed

This is a userlist question, but I think you will find that is because there is no seektable for the file. The internal player needs a seektable for jumping around in a file. Try "mythcommflag --video filename"
If there is in fact a seektable, please reopen and attach the result of mythfrontend -v playback

comment:3 Changed 12 years ago by adrian.wilkins@…

This also happens when your seektable gets corrupted in MySQL ; if this is happening with all new recordings, this is likely what is happening.

You may need to repair your tables. There are two commands that achieve this ;

mysqlrepair -p<password> --database mythconverg # while MySQL is running

cd /var/lib/mysql myisamchk -r *.MYI

You'll need to rebuild the seektables for all affected recordings. You can do a range with

mythcommflag --rebuild --all --allstart <start-of-range>

comment:4 Changed 12 years ago by anonymous

Gah, the second bit should read

cd /var/lob/mysql
myisamchk -r *.MYO

comment:5 Changed 12 years ago by anonymous

MYI!!! I previewed as well, I must be going senile....

Note: See TracTickets for help on using tickets.