Opened 12 years ago

Closed 12 years ago

#4392 closed patch (fixed)

mythsocket + mythbackend Windows patches

Reported by: andrei@… Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This patch enables backend to actually start accepting incoming socket connections on Windows.

I tested it with a "virtual tuner" (mpegrecorder with mpeg2 file).

Attachments (1)

backend.patch.gz (1.1 KB) - added by andrei@… 12 years ago.
unzipped gets classified as spam (please fix the trac's rules)

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by andrei@…

Attachment: backend.patch.gz added

unzipped gets classified as spam (please fix the trac's rules)

comment:1 Changed 12 years ago by David Bussenschutt <davidbuzz@…>

I tried this patch on SVN 15290+mythwelcome.patch+themereload_win32.patch, and it builds, but the Win32 frontend still seems unable to connect to the Win32 backend, with the same error as it gives without the patch. currently recompiling to confirm.

comment:2 Changed 12 years ago by David Bussenschutt <davidbuzz@…>

I can confirm that it occurs with and wihout the setup.patch for configgroups from #4391.

comment:3 Changed 12 years ago by andrei@…

This does not make this patch invalid, it just means that there may be other issues.

comment:4 Changed 12 years ago by andrei@…

Can somebody please take a look at this patch? It only changes MinGW-specific code.

comment:5 Changed 12 years ago by David Bussenschutt (aka buzz) <davidbuzz@…>

I've been using it successfully since it was initially posted. it's been coded into the win32-packager to use this patch for some time. Connection to the win32 backend works, despite my first comment/s to the contrary (I thought this was discussed on the dev list already?) This patch definitely improves things.

comment:6 Changed 12 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:7 Changed 12 years ago by danielk

Resolution: fixed
Status: assignedclosed

Fixed by [15627].

Note: See TracTickets for help on using tickets.