Opened 11 years ago

Closed 11 years ago

#4649 closed defect (duplicate)

Mythtv-setup crashed when attempting to scan channels

Reported by: anonymous Owned by: danielk
Priority: major Milestone: 0.21
Component: channelscan Version: head
Severity: high Keywords:
Cc: Ticket locked: no

Description

When attempting to draw or close the channel scanner mythtv-setup will randomly crash. Sometimes it just won't draw the scanner window and scan successfully, sometime the scanner window will be incompletely drawn and a fraction of it's intended size, sometimes it will just hard lock requiring a kill to exit mythtv-setup, and sometimes it will work normally. The rate of success seems to be governed by the size of the display. 800x600 is less likely to crash than 1280x720. Below are some of the error codes I've been able to capture using -v all. Lots of the time it crashes there is no segfault information passed on, it just dies. These errors have all been generated in the last few minutes running 15948. X Error: BadWindow? (invalid Window parameter) 3

Major opcode: 2 Minor opcode: 0 Resource id: 0x140069c

mythtv-setup: Fatal IO error: client killed

2008-02-12 17:10:20.729 MSqlQuery: SELECT data FROM settings WHERE value = 'UseArrowAccels?' AND hostname = 'BLAH' ; 2008-02-12 17:10:20.730 MSqlQuery: SELECT data FROM settings WHERE value = 'PopupHeightPadding?' AND hostname = 'BLAH' ; mythtv-setup: Fatal IO error: client killed

X Error: BadPixmap? (invalid Pixmap parameter) 4

Major opcode: 56 Minor opcode: 0 Resource id: 0x14007b1

mythtv-setup: Fatal IO error: client killed

Change History (3)

comment:1 Changed 11 years ago by Marc Randolph <mrandtx@…>

Dup of #4645?

comment:2 Changed 11 years ago by anonymous

This problem has been around for a long time, well before the multirec merge. When the screens are drawn correctly, scanning does work. It appears all the crashes are related to screen draws, not the actual scanning.

comment:3 Changed 11 years ago by danielk

Resolution: duplicate
Status: newclosed

Duplicate of #2909

Note: See TracTickets for help on using tickets.